Pi4 and v1 kits

I have a very strange problem with my diy zynthian (built almost 3 years ago according to version 1). everything works fine on rbp3 and buster image (v1 kit setup) but when I’m changing rbp3 to rbp4 I’m loosing my encoders. Works only click on first (layers) encoder. Anybody know what it can be? I have tried all wiring setups but without positive results.

have you taken a fresh image?

Yes, fresh image 2019-09-24-zynthianos-buster-lite-1.0.0-RC1.zip

And you update the system and changed the kit/wiring?

And you checked the physical wiring? Always takes ages when I opened my v1 Zynthian to get it running again.

The funniest thing is that when Z running on rbp3 everything is ok and when I change to rbp4 encoders not work. Back to rbp3 and back to order.

With different SD cards? I have a MCP23008 running with Raspi4. But no encoders, only 3 Action-Buttons.
Maybe you should show us boot logs

Hi @ejdzi
Nice to read from you again :wink:
What wiring config are you using? Prototype 4?


Yes, it’s prototype 4.

When you made the first boot of the SD. Has it been in the raspi3 or 4

First boot in raspi4. Then update. Still raspi4. Changing to raspi3 was only to see if there might be problem with phisical wires.

Hi, so is It only my problem? Nobody find that kind of behaviour while upgrading v1 with prototype 4 wiring to raspi4?

I am sorry I am annoying but if someone can check if kit v1 and prototype 4 wiring works with rbpi4 I will be extremely grateful. I’m not able to make encoders work.

I will try with an old v1 that i’ve somewhere …

I’ve just swapped out my v1/prototype-4 from rbpi3 to rbpi4 (recent Buster image) and I am also seeing encoder issues.

The Back and Select buttons don’t work, and the Layer and LoadSave buttons do work. The encoders don’t do anything when turned.

That’s exactly the issue. Thanx. Unfortunately I do not know nothing about solving this problem. Our Only hope in @jofemodo :smirk:

Its probably more accurate to say the Select encoder doesn’t work, and without a working Select button it is not possible to navigate to a screen to try the other encoders

Have you tried a USB keyboard? There are keymappings that will allow you to navigate around a bit, and you might be able to figure out if the other encoders are working.

Is there any knowledge that new rbpi4 has any differences in gpio pins layout comparing to rbpi3? Is this possible that is source of v1 kits problem?

What I have tried is the touchscreen, which works. So I can navigate to a screen which confirms all the GPIO based inputs don’t work. The 2 buttons which come through the MPC23008 work fine.

I’ll have a play now with python gpiozero to see if I can read any GPIO input events