Pianoteq License Key Activation from Webconf [SOLVED]

#1

Hi @zynthianers!

On the recently released version 6.4.1, pianoteq’s team have added a new CLI option that allows to activate the licensed software without the need of opening the Pianoteq’s native UI. This option simplifies the license activation procedure, specially for Windows and Mac users.

I just integrated this new option in the webconf tool, so now it’s possible to upload the licensed binary and activate it from there. Just update your Zynthian Software!! :wink:

Kind Regards!

2 Likes
#2

Thanks @jofemodo!

Your work (and that of pianoteq regarding cli activation) is highly appreciated.
Although Pianoteq is not open source or free software, the demo for arm and zynthian platform was one more reason for me building zynthian.

Thanks and God bless, Marius

1 Like
#3

Hmmm… it’s a little bit strange. I can activate Pianoteq after a fresh installation, but only my Electric-Pianos are in non-demo mode. The Hohner and the Steinberg are not activated…

Regards, Holger

On-Screen Status Info on Zynthian-UI: CPU-load, MIDI-IN, xrun, undervoltage & overtemperature
#4

Yes … it’s quite strange! I’ve 3 licensed instruments (Hohner, Steinwey D and Electric Pianos) and all the 3 are enabled. Are you using the last binary from Pianoteq, with the webconf activation method (Pianoteq GUI is not needed nevermore!)?

Regards,

#5

Yes… and in my Pianoteq account I can see that there is a Steinway D. Strange. Will try the next days again…

#6

I removed the config file by hand, reinstalled PT-6.4.1 and added the license key again. Now it works. I don’t know what I have done wrong before…

1 Like
#7

Hmmmm… trouble again. I just installed a fresh image again. Updated twice. Uploaded my PT-6.4.1 and tried to activate with my license and got a 500: Internal Server Error on the page http://zynthian.local/api/sw-pianoteq :fearful:

After that I removed the configuration via ssh (rm ~/.config/Modartt/*) and tried to add the license again. Same error…

Regards, Holger

[EDIT: This is reproducable…]

#8

Could you check the webconf tool logs?

#9

Ahhhh, yep, done that. The problem is located directly in front of the screen: I have changed my RPi3B against a RPi3B+… so I have to change my license on the Pinaoteq web page.

Activation Failed
An error occurred during the activation:
Your copy has already been activated on 3 hardware configurations. Visit the user area (https://www.pianoteq.com/user_area) if you want to deactivate an old hardware, or contact us at support@pianoteq.com

But it is good to know that we have an uncaught exception here if this happens (@mheidt: should I open an issue on github?):

INFO:root:Configuring Pianoteq License Key: *****-*****-*****-*****-*****
ERROR:tornado.application:Uncaught exception POST /api/sw-pianoteq (192.168.0.146)
HTTPServerRequest(protocol='http', host='zynthian.local', method='POST', uri='/api/sw-pianoteq', version='HTTP/1.1', remote_ip='192.168.0.146', headers={'Dnt': '1', 'Cookie': 'user="2|1:0|10:1553962449|4:user|8:cm9vdA==|1f3b895477d4aaaffeefab63601ebbcdf9cd789f0c71793968"', 'Referer': 'http://zynthian.local/api/sw-pianoteq', 'Content-Length': '630', 'Accept': 'text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8', 'Host': 'zynthian.local', 'Accept-Language': 'de,en-US;q=0.7,en;q=0.3', 'User-Agent': 'Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:66.0) Gecko/20100101 Firefox/66.0', 'Upgrade-Insecure-Requests': '1', 'Connection': 'keep-alive', 'Content-Type': 'multipart/form-data; boundary=---------------------------1849547432173242621635170081', 'Accept-Encoding': 'gzip, deflate'})
Traceback (most recent call last):
  File "/usr/local/lib/python3.4/dist-packages/tornado/web.py", line 1346, in _execute
    result = method(*self.path_args, **self.path_kwargs)
  File "/usr/local/lib/python3.4/dist-packages/tornado/web.py", line 2626, in wrapper
    return method(self, *args, **kwargs)
  File "/zynthian/zynthian-webconf/lib/pianoteq_handler.py", line 80, in post
    }[action]()
  File "/zynthian/zynthian-webconf/lib/pianoteq_handler.py", line 78, in <lambda>
    'ACTIVATE_LICENSE': lambda: self.do_activate_license(),
  File "/zynthian/zynthian-webconf/lib/pianoteq_handler.py", line 129, in do_activate_license
    result = check_output(command, shell=True).decode("utf-8")
  File "/usr/lib/python3.4/subprocess.py", line 620, in check_output
    raise CalledProcessError(retcode, process.args, output=output)
subprocess.CalledProcessError: Command '/zynthian/zynthian-sw/pianoteq6/pianoteq --activate *****-*****-*****-*****' returned non-zero exit status 2
ERROR:tornado.access:500 POST /api/sw-pianoteq (192.168.0.146) 3465.67ms

Regards, Holger

#10

@C0d3man
Could you give it a try?

#11

Hi Markus,

thx for fast fixing! Ok, no exception anymore! But there was no error message and it looks like Pianoteq is acitivated. I am sure that it is not, because I don’t had a free license.

Regards, Holger