Portamento and Legato in Zynaddsubfx

Hi folks.
I’m triyng to make a cover of Premiata Forneria Marconi’s Impresioni di Settembre (Link)

I’m not very good at sound design or keyboard playing, but I think that I get a decent result on the solo using zynaddsubfx on Ubuntu:

To make this I used the following setings:
mode: legato
portamento: on
portamento threshold: 5

But I can’t get the same result on zynthian. I try to set legato on, poly off and portamento on, but it doesn’t work. The sound is polyphonic (i can make chords), is not legato (it retriggers the modulations) and portamento hapens even if I cut the phrase.

I left my xiz files of the pad and lead that I’m using, in case that someone likes the sound:
0030-PFMIDS-PAD.xiz (1.8 KB)
0031-PFMIDS-LEAD.xiz (3.8 KB)

I will appreciate any help.

2 Likes

It’s been a while but I’m new to the table - did you get this to work @Andres ?

One thing that may be an issue is that ZynAddSubFX now has a single parameter for Poly / Mono / Legato (called polyType in OSC), instead of the separate poly and legato boolean parameters, and it would at least be more familiar to Zyn users if Zynthian had used this parameter instead. The old boolean parameters still exist, so they should work however.

Sorry, I’m a little bit disconnected, my speakers exploded so I haven’t used my zynthian for a while.

I tested last week end and the problem still there. I can set monophonic or legato via VNC, but not with the zynthian controls. I don’t know if there is something that I’m doing wrong.

So if I understand correctly, the value changes in the Zynthian display when you turn the knob, but there is no apparent change to the behavior of zynaddsubfx?

That’s right.

The value changes in the display when I turn the knob, I turn on mono and legato, but the sound is still polifonic without legato (it retrigger the envelope and LFO).

I’m using Raffo Synth as lead synth. But I want to use my old patches in Zynaddsubfx.

Are you using stable or testing branch? If you are using testing, please update and test again.

I’m using stable.
I will test on the weekend and comment the results, thanks :grinning:

On testing, the individual poly and legato mode parameters have been replaced with the new ‘assign mode’ parameter, which has the values poly - mono - legato - latch (the last one is only available in newer zynaddsubfx versions, like 3.0.6). I just verified that this parameter works as expected on testing, so if it doesn’t for you @Andres there something else wrong.

However, it seems that there is still an underlying issue with OSC parameters for zynaddsubfx which have two values. I haven’t debugged this completely, but it seems that Zynthian outputs numeric values (ints, 0 and 64) whereas the OSC parameters should have the type tags T or F, for true (=on) and false (=off), respectively, with no actual argument data. Sending the integers 0 or 64, or even 0 or 1, won’t work. (Verified with the oscprompt application).

This is evident in the remaining boolean OSC parameter, namely drum on/off which doesn’t seem to have any effect when adjusted on the Zynthian UI.

I also verified that zynaddsubfx when sent the proper messages, using oscprompt (e.g. “/part0/Plegatomode T”) does change its behavior as expected, so problem is definitely not in the engine.

EDIT: @Andres, a workaround might be to instead of the individual .xiz files load the complete ‘master setup’ (.xmz), which contains all the individual .xiz patches together with the complete Zyn setup, which then includes the poly and legato settings. Zynthian supports this (the only quirk is that you need to specify the same .xmz file for all zynaddsubfx layers), although on the stable branch, it is not obvious where to save the .xmz file so that it can be picked up as a selectable patch when loading the Zynthian layer. I believe it’s /zynthian/zynthian-my-data/presets/zynaddsubfx, but I’m slightly unsure because I’ve got various patches on my Zynthian to sort out the paths to user banks. On my machine, I believe I created a ‘master’ subdirectory using the webconf ‘New bank’ function (under Library->Presets and soundfonts) (i.e. the full path is/zynthian/zynthian-my-data/presets/zynaddsubfx/master) in which I put .xmz files,

I just fixed this problem in testing. I think stable is OK, but i could cherry-pick the commit if needed.
Please, update and test.

Regards,

Surely commit a1c84f2 must be needed to fix the binary parameter issue on stable? I couldn’t get it to work without applying that patch. Apart from that - great work @jofemodo !

It’s fixed, great work :smiley:

Last weekend I could not test. I’m useless.

This a new attempt to make the sound of PFM Impresioni di settembre, I feel the first one was better, but I made this from scratch using the VNC Engine connection.

PD: My method of sound design is move the knobs randomly until I get close to the sound I want.

1 Like