Problem with touch on Zynthian Kit V2


#1

Hi everyone,

recently i have found some time to play around with the zynthian and it sounds great and is a lot of fun.
One thing though i am not sure of is, does it have a working touch display or is everything done via the encoders?
Cause so far i have not found one situation where the screen would have responded to touch.

Settings in the webconf for Display is PiScreen 3.5(v2)
config details are:
""“
dtoverlay=piscreen2r-notouch,rotate=270
dtoverlay=ads7846,speed=2000000,cs=1,penirq=17,penirq_pull=2,swapxy=1,xohms=100,pmax=255
"”"

If yes, any tips what i might be doing wrong?

Regards,
Volker


#2

Hi @vbretsch!

The touchscreen should work out-the-box if you are using the last SD image.

Please, if it’s not working, try to login and try this command:

# cat /dev/input/event0 

Also, you can try to release a little bit the display’s bolts. Are you using the separators?

Regards


#3

Hi @jofemodo,

when looking at cat /dev/input/event0 and trying to use touch input nothing shows up and the zynthian itself does not respond to anything either.
I am using the separators that came with the bundle and loosening them a little does not change anything either.
I was using the latest image, but downloaded that again and did a fresh install with the same results…

Regards,
Volker


#4

So, you are using this one:

Please, can you update the software from the Admin menu and try again?

Also, check all the connections, and unplug and plug again the ribbon cable and check if it seems “OK”: the connectors seems to be well fixed, etc.

Regards,


#5

Did everything. Unplugged and replugged the ribbon cable. Did update again. Still the same. No reaction to touch and no output from cat /dev/input/event0 in the console.


#6

and yes. I am using thte zynthian_gorgona_edge_rbpi3_piscreen2-2017-10-23.img.
And after updating it even has my local check and display ip routine… :sunglasses:


#7

Curious … i can’t say. It’s really strange. Perhaps the display is broken …

During the mounting process, did you connect the display reversed by error? It’s possible as the connector allow both positions …

Have you tried to reconfigure the display again from the webconf tool?

Regards,


#8

I have tried to reconfigure from webconf just now. Does not change anything though.
I don’t think i reversed the ribbon cable during initial putting together. The display did show the splash screen from the beginning on.


#9

My touchscreen doesn’t work also…

best regards
Martin


#10

Hi @MartyMcFly!

Please can you confirm that you:

  • are using the last image

  • have updated the software

  • checked the output for this command:

     cat /dev/input/event0
    

while using the touch surface. What is the result?

Regards,


#11

Hi @vbretsch & @MartyMcFly!

Can you send me the output of:

# env
# lsmod 
# cat /boot/config.txt

Thanks!


#12

I am not at home anymore. Will try on friday and post results.


#13

2 posts were merged into an existing topic: Zynthian Kit v1: Display not working with last Gorgona Edge SD image


#15

So here it is. Output from env, lsmod and cat /boot/config.txt

env.log (2.1 KB)
boot_config.log (2.5 KB)
lsmod.log (1.7 KB)

Thanks for the help!
Regards,
Volker


#16

Hello here are my files:Config.txt (2.6 KB)
env.txt (2.1 KB)
lsmod.txt (1.4 KB)

TNX for your help…
Best regards
Martin


#17

Hi @vbretsch!

Please, could you tell me what USB devices you have connected to your Zynthian Box?

Thanks!


#18

One USB Device: a Studiologic Numa Nero masterkeyboard.


#19

Hi there,

any News?

Regards,
Volker


#20

Have you tried the last SD image, “Gorgona Next” preconfigured for kits v2?

Regards!


#21

A post was merged into an existing topic: Zynthian Kit v1: Display not working with last Gorgona Edge SD image