Problems accessing Native GUIs

I’m trying to access the native GUIs on Zynthian from another computer.

There are various methods mentioned here:

None of these options are working for me, and I think that page probably needs an update.

The information on setting up a VNC server is now obsolete as Zynthian now comes with one installed.

I can establish an X11 session as is described using:

$ ssh -Y root@zynthian.local

Any Xwindows commands launched from that shell (eg. xterm, aeolus) do indeed display correctly (in XQuartz on Mac OS). However, it doesn’t display commands that are launched by the Zynthian UI, which is what I need in order to be able to tweak the synth parameters. These windows instead go to a separate hidden desktop which is only accessible via VNC. Actually, there are by default two vnc servers running: a copy of the Zynthian UI display is on port 5900, and the desktop with the Zynthian native UIs is on port 5901. Therefore, what I actually have to do (eg. via Finder in Mac OS) is to open a connection to vnc://zynthian.local:5901.

If I disable the VNC server in the Zynthian UI configuration, I can no longer connect to the hidden desktop, but the windows still open there anyway, and won’t open in a forwarded X session.


  1. Is there a way to make the “live” sound engines open their UI in a remote X display, rather than in the VNC desktop screen?

  2. Is there a way to change the size of the VNC screen? I would like it to match the size of my remote display (1200x800) so the windows scale properly and I don’t have to scroll around it

I think at some point we changed the behaviour (broke) x-forwarding of engine GUI. I have found that x-forwarding is quite poor with an overhead that I was not expecting and that VNC actually works much better.

Currently the geometry for Xtigervnc is set by parameter $geometry = "1900x1200"; in file /etc/vnc.conf and not configurable from Zynthian UI or webconf. I have experienced (suffered) this issue without considering fixing it!!! I suggest you add a feature request to configure the resolution of this vnc session from webconf. As a quick workaround you could edit the file directly and change the parameter then reboot.

[Edit] An alternative (feature request) would be to allow configuration of resolution from within the VNC session, e.g. an application in the launcher.

1 Like

Thanks @riban. Setting the resolution in /etc/vnc.conf does the trick. I tried a couple of devices and found that an iPad works quite well for this. I’ll add a request to the github about this.