Should I?

So, I bought the previous version as a kit and it worked… about a dozen times, now its a brick with a screen saying error and its ip address… i can ssh into an perform commands, but i find empty log files, i can not login via web interface…

It was $300 US wasted on a dream i had long ago…

Thus i am only half convinced a newer version would be a better experience…

Heres a chance to sell me…

1 Like

HI @markdavis.md6!

The problem with your old zynthian seems a software problem more than a hardware one. Have you tried to re-burn the SD with the latest image? It should work OK …

Although the RBPi3 is quite limited when using some synth engines (Pianoteq, OBXd), it works nicely with most of other ones. You don’'t need to buy a new zynthian kit if you can live with some “XRuns” when using these engines: Pianoteq, OBXd or Surge.

Zynthian software is totally backward compatible. You can run the latest version on v1 kits.

Of course, i would be very happy of selling you a kit v4, as the “official” hardware has improved quite a bit too:

  • RBPi4 brings a lot of computing power, allowing to smoothly run Pianoteq or several instances of OBXd. You can add more effects, have more layers, etc. without reaching the limits.

  • Balanced Inputs & Outputs

  • 4 assignable push-buttons


But please, before thinking on buying a new kit, you should unbrick this fantastic v3 (or is it a v2?) Enjoy your current zynthian with the latest software, send some :face_with_monocle: and after that, you should have the best 1st hand knowledge to decide if you want a second zynthian on your life …


I have tried several versions, over the past 9 months or so… Im not sure when the background for the error screen went from white to black… but I did notice that that change over time…

Im not one to give up easily… and I LOVE the open source concept… but I have to say I am not loving the experience I have had here…

For clarity…

I cant say I look forward to being an ‘odd’ case 2 times in a row, and out … what another $300+ US …

I have read many posts and it seems like I am some ‘special’ case.

At least i should be able to re-purpose the RPi3.

Hi @markdavis.md6!

We will fix your zynthian for sure, my friend.


  • send a screenshot of your webconf panel.

  • If you see the error screen, the UI’s log shouldn’t be empty, Please login with SSH and send me the output of this command:

    journalctl -u zynthian

If this doesn’t give us any useful info, you could send me your zynthian. A standard “registered mail letter” can weight upto 2 kg and it’s quite cheap and although not the faster way, it normally reachs its destiny :wink:


1 Like


So as I mentioned, I cant login to webconf.

The GUI logfile is complaining of missing .py file, and a PNG file error with unknown gamma or something like that…

But more interesting is when I login with PUTTY via ssh - the shell script thats triggered has errors…

and I am the only one with such errors??? really weird.

If I am honest - it would appear an Apple style compulsion to upgrade has been adopted.

If I were to upgrade to the new kit, and if it worked… it’d never see the internet and become bricked like what happened here…

If only I could find the SD image that worked…

Anyway… heres the output you requested…

new 1.txt (39.9 KB)

Dec 20 17:40:57 zynthian startx[497]: ImportError: /usr/lib/python3.7/lib-dynload/ invalid ELF header

Faulty SD card?

I run the latest image on a v2 kit retrofitted with a pi4, and a homebrew pi3 set with no errors at all. Try a different sdcard and please explain with lots of detail how the web login fails for you.

Hi Baggypants,

I am trying another SDCard right now… just wanted to say…

When I attempt to connect to webconf - when connected same as with ssh - that does work… Chrome reports that the connection is refused.

Now let me ask this… are you convinced the webconf server is still functional?

webconf is an application that runs on the zynthian. If the image is corrupt then this is likely to be affected like the main zynthian application.

yes, I agree

I had some troubles to log in too because of the use of https protocol. By using http://zynthian.local it was okay.


Now webconf works… sorta… it shows the first screen pretty reliably, and I did get the attached log file when clicking on the menu; UI-Log. But being able to open another page is rather hit or miss.

1 Like

Ooops forgot the log file…

zynthian24.txt (21.3 KB)

I don’t believe you mentioned your zynth was running in hotspot mode, that would have been useful! And it’s a bit weird it has three ip addresses, do you have the wired and wireless interfaces both connected? If you have wired, use that and disable the hotspot for now.

A quick look at the log file shows that jackd server doesn’t start. Without jackd up and runnig, zynthian-ui won’t start.
While webconf is now functionnal, check your hardware settings.

Success… Sorta…

Well I could fix why jack wouldn’t start… wrong audio card…

I bought the kit in feb of 2019 - so I dont know what version its supposed to be. I found my receipt from paypal - and its not showing version there.

V2 kit allows the zynthian to show a UI… but now I have no encoders…

I did enable the touch widgets, and can fudge around in the UI… I still need to connect to MIDI and see if I can hear audio… but without encoders, with this display, its so cumbersome.

You probably need to go back to the web interface and change your hardware wiring to match whatever your kit is using. Since you don’t know for sure which kit you have, you might try selecting Mcp23017 Encoders first.

As seen in the wiki fir V2

  • Display: PiScreen 3.5 (v2)
  • Audio: HifiBerry DAC+ / HifiBerry DAC+ADC
  • Wiring: MCP23017_EXTRA

Confirmed… V2 is the only profile that works best.

Oh well.

Thanks guys

1 Like

Hurrah, that’s great:

  1. You didn’t loose 300€
  2. you’ve maybe learned something new about your lovely zynthian
  3. You’re now able to go for a :face_with_monocle: