SOFTWARE UPGRADE "Webconf"


#21

Hi @smespresati,

I think the feature start audio =>MIDI is the aubio library: You can create MIDI from audio, like guitar/voice/… but you need an audio input (USB-audio-stick, PiSound, …).

Regards, Holger


#22

Hi @C0d3man,

Thanks for your answer. I did not know what aubio was. I was googling a bit looking for info and now a have a slight idea of aubio, however most the info I’ve found is intended to programmers. Perhaps you can point me where I can find some info of using aubio.

Thanks, Jose


#23

Hi @smespresati!

You don’t need to know about aubio, but have a soundcard with audio input and enable the option in the Zynthian admin menu. The “aubionotes” program will generate MIDI events from the audio input. It will try to detect when a note starts and what pitch, generating a “note-on” MIDI event.

Anyway, here is the main documentation for Aubio:

https://aubio.org/documentation

Regards!


#24

Amazing work! Only one question: the snapshot feature has to be deleted in some way to not have conflict between Multylayer and Snapshots?


#25

Yes, @Ramsi. Your old snapshots will not work in multilayer, so better delete it. You can do it from command line or with SFTP.

Webconf snapshots are identical to multilayer. No changes, so it should work. Anyway, there are some bug in snapshots feature, specially when using MOD-UI layer … i have to fix it!

Regards!


#26

Great Work Fernando,

What do I have to do, to get the waveshare32 (GPIO) into the list?

thx,
Markus


#27

Could it be, that the wpa_supplicant will be overwritten?


#28

Yes, sorry, it’s my fault :blush: I will solve it ASAP.

Regards!


#29

After a reboot, the following page, should be Reboot again.
Stupid users like me are pressing Refresh and are going to reboot the machine all the time.


#30

It’s solved. It will overwrite the file the next update, but after that, never more :wink:

Regards!


#31

Hi guys,

I have a second Rbpi which I use for testing. Seeing how easy is now configuring devices throught the new webconfig I decided to try it in a second Zynthian unit (for testing purpose). This second unit has the rbpi 2, the 7 inches raspberry official display…and a usb sound interface M-Audio Fast Track Pro.

Webconfig worked just fine…except the sound interface. I started with a fresh gorgona image which I updated (twice) then I’ve choosen USB option to configure Audio and rebooted. What I can notice is test audio works…but test midi doesn’t. I also noticed that (using command aplaymidi over SSH) mid files are not played…but no errors are shown.

Any idea on how to deal with this issue will be welcome.

Regards, Jose


#32

Currently, you have to load some synth before testing MIDI. I’ve to improve this :wink:
Try with a keyboard creating some layer first …

Regards!


#33

Thanks @jofemodo, I’ll try it this afternoon.


#34
  1. Try to start “MIDI test”.
  2. Go back and add FluidSynth engine to Channel #1. Choose a piano.
  3. Go back and add another FluidSynth engine to Channel #10. Choose a drumset (at the end of the list)
  4. Go back and add FluidSynth engine to Channel #… Goto 2

For this MIDI song the following setup is normaly used (GM compatible):

channel 1 [bank=0 prog=0] Yamaha Grand Piano
channel 2 [bank=0 prog=32] Acoustic Bass
channel 3 [bank=0 prog=26] Jazz Guitar
channel 4 [bank=0 prog=65] Alto Sax
channel 5 [bank=0 prog=89] Warm Pad
channel 10 [bank=128 prog=32] Drums Jazz

Regards, Holger


#35

Hi @jofemodo and @C0d3man,

It works…but a noticeable latency is present when playing the keyboard. The rbpi 2 with my HifiBerry worked without noticeable latency, so I must assume the issue is related to the usb sound interface hardware or setup. I wonder whether a tweak in any config will help (i don’t know which config to tweak if any).

Regards, Jose.


#36

Yes. Cheap USB-soundcards are not the best suited for low-latency applications, like zynthian.
Anyway, you could try to modify the “jackd” options (buffer size and number of buffers) from the webconf …

Regards!


#37

@smespresati

just read that the following should be the best for jack using USB devices:

  • sample-rate 44.1kHz (if your device support 48kHz try this also)
  • period: 64 / 128 / 256 (smaller means higher CPU load but lesser latency) (option -p as low as no xruns appears (value must be a power of 2, and the default is 1024))
  • nperiod: for USB devices you should use 3 (option -n normaly 2 or 3)

Regards, Holger


#38

Jeje! @C0d3man explain it a lot better than me :blush:


#39

Hi guys,

I agree. @C0d3man takes their time helpping everyone that need it. Thanks for your unvaluable help.

@jofemodo I think you’re focused in writing code, so I prefectly understand your short answers.

I’m trying different setup as @C0d3man suggested but latency is still there. These are my sound interface features:

24-bit/96kHz audio interface with dual mic/instrument preamps
balanced/unbalanced analog I/O
S/PDIF coaxial; MIDI I/O
¼” headphone output with level control and A/B source switch

In the past I was using this interface in a windows environment. It was hard to achieve a reasonable low latency. I think is not worth a deeper research to make it work with Zynthian.

Thanks.


#40

Hey, nice upgrade again!

But… is Dexed broken (again??)
In the Pedalboard webthingie, neither input and output are connected.

Cheers,
Kees