Starting my zynthian build: alternative LCD, DAC, encoders


and about the values of the A/B/Switch GPIO-pins?


When you select a wiring layout, these values are adjusted accordingly. You can modify the values if you want, but in such a case it’s recommended to use the “CUSTOM” wiring layout, that’s empty for that purpose. If your wiring layout can be interesting for other people, we could add it to the list :wink:



Perhaps my board or my encoders are defective :frowning: I’ve tested all possibilities and doesn’t work properly. Now have just the enc 4 wired at board. Left, Right and button have only 1 behavior: Right.


Sticking with the Motor 61 theme. This keyboard doesn’t clear down notes clearly. I can frequently trick it into holding a note by syncopated playing.

I have the Roland A-88 via USB and a Nord Modular G2 via MIDI Input on the same patch and I don’t get the effect with that.
That’s a bit of a problem … :disappointed_relieved:

Let’s see what Behringer say.


All works, but doesn’t with the expected behavior. The first encoder
just works when I use the second. The second just alternate between
the Layer List and > Admin screens. The third, alternate between Save

Remove on KY-040 encoders resistor R3 (10 kohm), as it interferes with other pullups (R1 and R2). Desolder it or just scratch all resistive layer away (usually green or black color) until white ceramic becomes visible.


what pin wiring between all in one module to waveshare 3,5 lcd a

Failed starting software [solved]
Tedy's Thread

Please search this forum for waveshare. There are some ppl that solved it


Tomorrow I’ll try this solution and report asap


After desolder the R3 from encoder 4, the “select” function works as expected, but the scroll function doesn’t work :frowning:

I’ve wired just the encoder 4 to all-in-one board. What is the next step? My config web conf values are the same from this reply: Starting my zynthian build: alternative LCD, DAC, encoders


Are you absolutely sure the encoder board has no shorts or dry joints and everything is in the correct place?
Do you have access to a multi meter and can check the expected responses as you use the encoders and switches?
Do you have a magnifying glass to examine the solder joints and check fro hairline shorts between tracks and dry joints on pins?
If you have these sorts of errors no amount of software configuration will sort the issue out for you.

You need to be sure that the correct response is present at the main chips pins and that the correct pins are wired back to the correct pins on the Pi.


I’ve checked all solder joints and don’t found any shorts or issue. I’ll make a simple video with the solder side view


Somewhere on this forum Jofemodo described a procedure to see if the I/o chip on the encoder board was present have you tried that?


After desolder the R3 from encoder 4, the “select” function works as expected,
but the scroll function doesn’t work :frowning:

I don’t have All in one board, but same type encoders as you have - KY-040. After removing R3 on all encoder boards i got my homemade board to work, but reacting to encoder movement and selecting with knobs leaves room to improvement. I don’t have here same type encoders as Jofomodo uses, so maybe this is an another issue, where KY-040 encoders behave differently. I have some ideas, but first i must test here.

Alternative way is wiring all encoder boards Vcc pin to +5V. MCP23017 have internal 100k pullups, but this may be not enough. At least recommended pullup on TTL logic are somewhere 5…10k range. This is a probable reason, why these 10k resistors on encoder boards interfere with MCP23017 pins, if encoder Vcc pin left unconnected.

Update: removing all resistors on encoder boards helped my setup, now encoders and switches work as expected. One problem remains - i have feeling that in zyncoder library (zyncoder.c) not all input pullups on MCP23017 are enabled, but this is another issue to be doublechecked.


Well I can’t duplicate the key holding so we will assume it’s ok for now.

Behringer were pretty good from the support point of view but it would have cost if it wasn’t regarded as broken and the amounts were probably heading for the overall cost of the device. I’d rather go and see Kraftwerk at Jodrell Bank . . . Bluedot . . .July 2019

With many external controllers particularly if they are laid out in ranks (Motor61 encoders) the presence of the volume modifier in position top/left makes for a fairly wierd mapping and you can map multiple controllers to the same MIDI controlled source so you loose one in 4 encoders.

I don’t know how much this is relevant but it’s certainly a fair way down the path of easy multiple encoder mapping.


I’ll to try the removal of all resistors and to test again. Thanks for your help!


Hi @wyleu! I’ve changed the partner to my zynthian. I’m using the motor 61 with ipad to minor gigs and other setup with more keyboards and gears. I’ve bougth a brazilian clonewheel organ (TOKAI TX5) two months ago to decorate my living room and the zynthian will be the best choice, once the organ doesn’t have other sounds than hammond simulation.

But anyway, I’m following your discoveries and tests about the Motor 61. It’s a great controller and I’m falling in love by it. Please keep your tests, they will help a lot of people like me.


Ohoho! My Motor 61 is on the way … jejeje! As soon as i have it, i intend to implement the MIDI-feedback so we can have nine motorized drawbars for setBfree :wink:


#TeamBehringerMotor jajajajajajaja


Getting Program Change out of it is a little involved. . . .

The suggestion is use the pads.



i had the same issue like jonathaslacerda with the KY-040 Encoders. I removed all 3 resistors. It works! :grinning:

Thank you!