Trying to get Landzo 3.5" Display Touch-feature working


#1

I might not be describing it correctly, but to connect my Landzo 3.5" display I have to get the two columns of pins to trade places - is this correct? I’m using the AudioInjector DAC. The display works normally plugged directly onto the RPi pins. Are the OzzMaker PiScreen 2 pins flipped, or am I missing something fundamental here? I couldn’t find a pinout of the PiScreen 2 to compare to mine. Sorry if I’m missing an obvious resource! Everything (display and audio test) works fine with the display wired in the photo (except touch of course):

Thank you!


#2

Maybe this post

Or @thebez can help you


#3

Thank you! Yes, I’ve checked that post again today - it was the original way I found out about the Landzo display, I think? And the alternate cabling wiki article. I can’t tell from the photo but maybe they ran into this too. I mean what I have works so far (without touch), Suppose I could make another small 26 pin cable that flips them but was wondering if I was missing something since the Landzo is direct hat style. Well, and I’ve never made a ribbon cable before! (And I gather the touch not working is a driver issue and not a connection issue?) :confused:


#4

Hi @rockwater!

The official ribbon cable doesn’t transpose any pin. The 3 connectors are assembled with the same orientation and the pin order is conserved in all of them. The 26 pin connector is flipped after assembling, so it can be connected easily to the PiScreen row-pin connector, but this doesn’t affect the pin-order, that is the same that the RBPi.

Regards,


#5

I’m so confused :cry: I don’t understand why connecting it like I did in the photo works. I even disconnected the NC pins. I’ll test more with a multimeter and compare to the Landzo pinout documentation. (I wouldn’t have used those color cables at all but the display is also female.)


#6

Hi again, Please bear with me I’m just trying to understand and possibly share information that might help others too. I’ve made this crude graphic to help illustrate the way I have to hook up my Landzo 3.5" display (Waveshare 35a clone). Since this Landzo hat-style display works when connected directly to the AudioInjector, this must mean the male header on the OzzMaker PiScreen has the rows flipped, correct? All 4 encoders are working fine. I have NOT tried each pin with a multimeter though. If some of the AudioInjector male pins are faulty maybe I am just “getting lucky” by which pins are actually needed by the Landzo display. BUT, with my working flipped-rows style, I was able to disconnect each NC pin (referencing the Landzo pinout graphic) and everything still worked fine. Of course, as always, I have not learned how to add the drivers to make Touch work so I don’t know if that would have been affected. Any thoughts? I know there’s been trouble with the AudioInjector in the past, just seems odd everything is working - if I just hook it up differently. If I had just gotten the OzzMaker PiScreen all this could be avoided… Landzo was just so cheap :frowning: Just hoping this doesn’t make Touch inoperable when I try to get that working. Go easy on me guys!

landzo%20pinout

Hmm it looks like @nixator used a similar screen but with a custom cable? I have not heard from @thebez. Maybe I should get a vice and a male header facing downward with the Red on the outside and replace the female 26-pos on the official cable?


#7

Have you tried the waveshare32 wiring, i am using? there are posts in the forum here.


#8

Hi! I’ve searched “waveshare32” but I cannot find the exact thread about wiring, or scrolling through related threads. Do you mean to get Touch working or just in general (or both)? Seeing others’ solutions, I have no problem just doing what it takes to do custom wiring. I was just surprised the cheap Landzo 3.5 worked as a hat but worked differently when using the official ribbon. Could you link me the particular thread about the waveshare32 wiring? Thank you for your patience, I’d love to do some testing now but I gotta run to work! :slight_smile:


#9

#10

I tried both of the straight connections (in the red images) with the PROTOTYPE-4-WS32 selected but had same results. Either white screen, RPi will not power on. Or unpowered screen and Zynthian boots. If I transpose the two rows, like in the original photo, it works perfectly, all encoders, audio, midi, just no touch. i havent tried to install the waveshare drivers via ssh, or HDMI with Qwerty or anything like that. that is how I would get Touch working, correct?

Something unrelated - but I didnt know if it was worth another thread - what is the lowest usable resolution for Zynthian? I’ve also been thinking of trying a small monochrome OLED display if I can find one that works with the RPi. But maybe that would be driver hell and I don’t know Linux very well. It would be amazing to have Zynthian functioning on such a tiny screen to me. A little like an old synth. No touch though of of course. Anyone try this? I havent found anything in the discourse.


#11

Show us a detailed picture of the wiring and a screenshot of the webconf dashboard.
Maybe the 3.5 needs his own wiring you need to investigate.


#12

Do all 4 rotaries work? I wonder that you just can turn cables. I had to move 3 pins to get the waveshare32 working.
Did you follow everything we wrote about touch and waveshare32? Did you remove that one line in webconf? I changed something in the custom directory for waveshare32. Might needed for waveshare35 as well.


#13

Hi! I haven’t changed any pins or removed anything in webconf. Choosing from the list in webconf, Waveshare3.5A and Waveshare GPIO Only work. All four encoders and buttons work, I can change parameters in Dexed, do everything. DIN 5 MIDI IN works perfectly, no latency. I SSH’d in and ran the encoder test and they were all outputting figures (but I assumed they were since they all work in the interface). The only thing that doesn’t work is Touch. Can I use SSH and add the drivers or is it not that simple? I also hooked up HDMI so I could login and see Zynthian boot without the display when I tried Waveshare 3.5B and C. I think one of those worked but the colors were inverted.

Since all of the encoders and MIDI In and Audio Out is working, I am assuming the Waveshare3.2 re-wiring wouldn’t apply here? Or am I misunderstanding what we are trying to diagnose? The “documentation” for this Landzo 3.5 display says to use the Waveshare 3.5A drivers from Waveshare’s site (for Raspian) but maybe it is not sticking completely to spec.

I’ll attach photos (but probably nothing new for you) but maybe I can draw up my own Lanzo pinout and overlay that on the RPi/AudioInjector/Zynthian pinouts to see if there are conflicts. Earlier, I disconnected all of the pins marked “NC” by Landzo and the display still worked perfectly. Is there any debugging script etc I can run that would give you or others more info?

(some pins look a little un-set in one of the photos but ive re-set them, tried this a few times)






#14

Read everything in the forum rgd waveshare32 and touch. I don’t think that it’s the driver. Maybe webconf parameter.


#15

Ok! I will try to slow down and try the solutions in that thread. :relieved:


#16

Darn if this enclosure was scaled up a bit, and a bit more modular…


#17

The irony of not shipping a raspberry pi case to the UK is not lost on me…
Looks interesting… Much land for encoders…?


#18

They won’t ship to UK? Weird!

Doesn’t seem like much space, no. :confused: Maybe someone could make it work but barely seems worth it, well only because I have the full size AudioInjector. Maybe I should look into the lasercut wood case, I haven’t looked at US pricing. I do have a powerdrill but no saws (hah).


#19

The midi connectors are probably the biggest user of panel space. Unless of course you go for mono 1/4"s everywhere.


#20

True, true. I’d love to keep it proper DIN style but these 1/8" to MIDI connectors are becoming more popular in the modular and euroracks to save space. Well some, some stick to proper 5 DIN.