USB Sound device are working?


#1

hi, using an external usb audio device, audio input is usable on zynthian?i speak in general, 'cause even changing on webconf, usb device is never used. System recognizes device correctly (it’s shown on alsamixer with all parameters) but, for example, inside MOD, no audio input or output appears except for hifiberry’s out.
there’s something still not ready and need a manual adjustment, or i’m doing something wrong?
Thanks


#2

Hi @ivanmonterosso!

Are you trying to use 2 audio devices with Zynthian? It wont work by default …
It’s a complex matter, but generally is not a good idea to use Jack Audio with 2 different devices simultaneously. Anyway, you can try by tweaking the “jackd” options. I haven’t tried recently and who know … :wink:

Good luck!


#3

Thanks for reply… however i want use Just One at once… would try the USB with input, but sound remains on hifiberry. I tried to change hw id on jack string present on webconf field, but nothing changed… Maybe i have to change It dierctly in terminal?


#4

Could you send your “/boot/config.txt”?


#5

Sure, l Will do tomorrow


#6

but, here can’t upload txt… do i have to paste it here?


#7

You can use “preformated text” to post code !


#8
# For more options and information see
# http://www.raspberrypi.org/documentation/configuration/config-txt.md
# Some settings may impact device functionality. See link above for details

# Tell bootloader to use initram image
#initramfs initrd.img-4.1.13-v7+

# Load RT Kernel for RBPI2
#kernel=kernel7-rt.img

# uncomment if you get no picture on HDMI for a default "safe" mode
#hdmi_safe=1

# uncomment this if your display has a black border of unused pixels visible
# and your display can output without overscan
#disable_overscan=1

# uncomment the following to adjust overscan. Use positive numbers if console
# goes off screen, and negative if there is too much border
#overscan_left=16
#overscan_right=16
#overscan_top=16
#overscan_bottom=16

# uncomment to force a console size. By default it will be display's size minus
# overscan.
#framebuffer_width=1280
#framebuffer_height=720

# uncomment if hdmi display is not detected and composite is being output
#hdmi_force_hotplug=1

# uncomment to force a specific HDMI mode (this will force VGA)
#hdmi_group=1
#hdmi_mode=1

# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes
#hdmi_drive=2

# uncomment to increase signal to HDMI, if you have interference, blanking, or
# no display
#config_hdmi_boost=4

# uncomment for composite PAL
#sdtv_mode=2

# Disable Splash Screen
disable_splash=1

# Disables dynamic frequency clocking
force_turbo=1

# Uncomment to overclock the arm. 700 MHz is the default.
[pi2]
arm_freq=900
core_freq=250
sdram_freq=450
over_voltage=2
[all]

# Uncomment some or all of these to enable the optional hardware interfaces
dtparam=i2c_arm=on
dtparam=i2s=on
dtparam=spi=on

# Uncomment this to enable the lirc-rpi module
#dtoverlay=lirc-rpi

# Additional overlays and parameters are documented /boot/overlays/README

# Disable Blutooth Support for HifiBerry compatibility with RBPi 3
# Swap back the ttyAMA0 to GPIO
[pi3]
dtoverlay=pi3-disable-bt 
dtoverlay=pi3-miniuart-bt
[all]

# Enable MMAP support (Jackd, etc.)
dtoverlay=i2s-mmap

# Soundcard Config


# Display Config
dtoverlay=pitft28-resistive,rotate=90,speed=32000000,fps=20

# Adjust Serial Port Clock to allow MIDI baudrate 31250
[pi2]
init_uart_clock=2441000
init_uart_baud=38400
dtparam=uart0_clkrate=3000000
[pi3]
init_uart_clock=39062500
init_uart_baud=38400
dtparam=uart0_clkrate=48000000
[all]

#9

It seems OK. Hifiberry driver is not loaded, so USB device should be the only one …
Can you send the “lsmod” command output?


#10

sure,
here it is:


Module                  Size  Used by
brcmfmac              222874  0 
brcmutil                9092  1 brcmfmac
cfg80211              543027  1 brcmfmac
snd_usb_audio         147900  2 
snd_hwdep               6688  1 snd_usb_audio
snd_usbmidi_lib        22487  1 snd_usb_audio
rfkill                 20851  2 cfg80211
snd_rawmidi            23790  3 snd_usbmidi_lib
fb_ili9340              3647  1 
fbtft                  34966  1 fb_ili9340
snd_seq_device          5504  1 snd_rawmidi
syscopyarea             3225  1 fbtft
sysfillrect             3826  1 fbtft
snd_soc_pcm512x_i2c     2718  1 
snd_soc_hifiberry_dacplus     5055  2 
snd_soc_bcm2835_i2s     6546  2 
sysimgblt               2480  1 fbtft
snd_soc_pcm512x        21992  1 snd_soc_pcm512x_i2c
fb_sys_fops             1741  1 fbtft
snd_soc_core          179915  3 snd_soc_pcm512x,snd_soc_hifiberry_dacplus,snd_soc_bcm2835_i2s
snd_compress           10384  1 snd_soc_core
evdev                  12423  2 
snd_pcm_dmaengine       5894  1 snd_soc_core
joydev                  9988  0 
snd_pcm                98501  6 snd_soc_pcm512x,snd_usb_audio,snd_pcm_dmaengine,snd_soc_hifiberry_dacplus,snd_soc_core
snd_timer              23968  1 snd_pcm
gpio_backlight          3105  0 
snd                    70032  14 snd_compress,snd_hwdep,snd_usb_audio,snd_timer,snd_rawmidi,snd_usbmidi_lib,snd_seq_device,snd_soc_core,snd_pcm
i2c_bcm2835             7167  1 
bcm2835_gpiomem         3940  0 
spi_bcm2835             7596  0 
clk_hifiberry_dacpro     2812  1 
uio_pdrv_genirq         3923  0 
uio                    10204  1 uio_pdrv_genirq
fixed                   3285  0 
i2c_dev                 6913  2 
stmpe_ts                4779  0 
ipv6                  408971  26 

just keep in mind another thing i noticed: with USB audio plugged in, and USB audio device is choosen on webconf, after reboot the page is this way (without any volume control)
and zynthian unable to load the default shapshot…and if trying to force load, it gives the splashscreen with “red error”.

after a second reboot , webconf page looks this way, theorically right, but sound remanis on hifiberry.
If i pull out usb device, but remain in USB device setup, then reboot, no more error occours, and webconf page stays in this way.
Obviously sound is on hifiberry, the only one board present :wink:


#11

That’s very strange. The HifiBerry drivers are loaded and it shouldn’t be, as there is no “dtoverlay” for that in your “boot/config.txt”. Please, can you check again your “boot/config.txt”?


#12

by now i’m trying several things with original setup for other issues… i will reproduce again from scratch by inserting usb device, choosing from webconf, rebooting etc… then give you bootconfig… it’s ok?


#13

Correct :+1:
After booting, send your “boot/config.txt” and the “lsmod” output …


#14

want to know a joke?.. zynthian turned off. USB device inserted, still on hifiberry, (webconf was still on USB device with no success), changed to hifiberry, rebooted,…this is config.txt

# Uncomment some or all of these to enable the optional hardware interfaces
dtparam=i2c_arm=on
dtparam=i2s=on
dtparam=spi=on

# Uncomment this to enable the lirc-rpi module
#dtoverlay=lirc-rpi

# Additional overlays and parameters are documented /boot/overlays/README

# Disable Blutooth Support for HifiBerry compatibility with RBPi 3
# Swap back the ttyAMA0 to GPIO
[pi3]
dtoverlay=pi3-disable-bt
dtoverlay=pi3-miniuart-bt
[all]

# Enable MMAP support (Jackd, etc.)
dtoverlay=i2s-mmap

# Soundcard Config
dtoverlay=hifiberry-dacplus

# Display Config
dtoverlay=pitft28-resistive,rotate=90,speed=32000000,fps=20

# Adjust Serial Port Clock to allow MIDI baudrate 31250
[pi2]
init_uart_clock=2441000
init_uart_baud=38400
dtparam=uart0_clkrate=3000000
[pi3]
init_uart_clock=39062500
init_uart_baud=38400
dtparam=uart0_clkrate=48000000
[all]

this is lsmod:

    Module                  Size  Used by
    brcmfmac              222874  0 
    brcmutil                9092  1 brcmfmac
    cfg80211              543027  1 brcmfmac
    fb_ili9340              3647  1 
    fbtft                  34966  1 fb_ili9340
    rfkill                 20851  2 cfg80211
    syscopyarea             3225  1 fbtft
    snd_soc_pcm512x_i2c     2718  1 
    snd_soc_hifiberry_dacplus     5055  0 
    snd_soc_bcm2835_i2s     6546  2 
    sysfillrect             3826  1 fbtft
    snd_usb_audio         147900  5 
    snd_soc_pcm512x        21992  1 snd_soc_pcm512x_i2c
    snd_hwdep               6688  1 snd_usb_audio
    sysimgblt               2480  1 fbtft
    snd_usbmidi_lib        22487  1 snd_usb_audio
    fb_sys_fops             1741  1 fbtft
    evdev                  12423  2 
    snd_soc_core          179915  3 snd_soc_pcm512x,snd_soc_hifiberry_dacplus,snd_soc_bcm2835_i2s
    snd_rawmidi            23790  3 snd_usbmidi_lib
    snd_compress           10384  1 snd_soc_core
    joydev                  9988  0 
    snd_pcm_dmaengine       5894  1 snd_soc_core
    snd_seq_device          5504  1 snd_rawmidi
    snd_pcm                98501  7 snd_soc_pcm512x,snd_usb_audio,snd_pcm_dmaengine,snd_soc_hifiberry_dacplus,snd_soc_core
    snd_timer              23968  1 snd_pcm
    snd                    70032  15 snd_compress,snd_hwdep,snd_usb_audio,snd_timer,snd_rawmidi,snd_usbmidi_lib,snd_seq_device,snd_soc_core,snd_pcm
    bcm2835_gpiomem         3940  0 
    i2c_bcm2835             7167  1 
    gpio_backlight          3105  0 
    spi_bcm2835             7596  0 
    clk_hifiberry_dacpro     2812  1 
    uio_pdrv_genirq         3923  0 
    uio                    10204  1 uio_pdrv_genirq
    fixed                   3285  3 
    i2c_dev                 6913  2 
    stmpe_ts                4779  0 
    ipv6                  408971  26 

Sound is on USB :open_mouth:
And… most of all: MOD has audio input present


#15

Woooooaoooo!! :smile::smile:

This is a problem with the ALSA subsystem and the way devices are sorted. As i told you, connecting 2 different audio devices to zynthian will be quite tricky. :mage:

Anyway, there are documentation about how to change the order of devices. For instance:

http://alsa.opensrc.org/MultipleCards

https://www.alsa-project.org/main/index.php/Setting_the_default_device

regards


#16

Yes, i noticed :grin:… For me only one is enough… Will finally experiment with audio input and… That veery interesting audio>midi function :wink:


#17

And very experimental too … jeje! Probably you would like to “tune” the audio=>MIDI conversion parameters.

Regards!


#18

yes, would tune… any tips where to change them?
thanks


#19

Try this file:

/etc/systemd/system/aubionotes.service

But your changes will be overwirten everytime you update the software. We should add this to webconf tool :wink:

Regards


#20

create github tasks…