Using the MOD-IU interface

Hello !

I manage to log onto the Zynthian http page, very useful to manage audio downloads and snapshots.
Now I wanted to use the MOD-IU page (@IP:8888 or @IP:9000 ?) but that doesn’t work (tried with XP and Seven).
Doing so I put the Zynthian into UI-MOD (special layer), but it still doesn’t work :thinking:

What exactly is it I’m overlooking here?

See you soon,

Just fired it up on zynthian-ceed.local without any problems . . .

It seems to all work . . .

Do you get any messages in the UI log in webconf . . .?

It’s under Interface in the menus.

This is the part I have overseen (well, one of the many, many parts actually)…Thank you sir I will try to produce this promising miracle after my ice cream cone (pistache-chocolate, the kids ate the last vanilla-chocolate cones)

1 Like

Sorry to take this issue all the way back to point A…I succeed to log onto the Zynthian using the path
But the other path ‘zynthian.local’ doesn’t lead me anywhere.
Furthermore my pc is logged to my local network using wifi, and the Zynthian is logged to my computer using a Rj45 cable. The Zynthian is using a network adress that doesn’t correspond to my local network:

The ip adress of the pc is ‘basic’ 192. 168.1.39, using the dhcp of the router, and I can’t seem to change the ip adress of the Zynthian for them to be in the same network.
Is this why the ‘zynthian.local’ log on doesn’t work ?
Is this why I can’t seem to link the Zynthian to the outside world? (I would love to ‘download’ the new ZynPad step sequencer for instance)

If anyone has any hints I’d be happy to learn some more about the use of my Zynthian.
PS : Check out the simplicity of my setup (only Octatrack and Zynthian for the moment, guitar/vocals are on the way!)

That’s a PC issue, and I think there is an explanation . . .

Assuming you’re using a Pi 3 or 4, you can connect your Zynth to the network from the webconf (look for the word “wifi” on the main page). That should help. It works for me.

I do not really remember and I don’t have my zynthian with me, but Shouldn’t be mod-ui activated from zynthian UI in the admin menu ?

Ok thanks @wyleu this means I’n not (for once) being a complete loose end on this type of technical issue.
I don’t feel the need to use the ‘zynthian.local’ log on, i only want a way of being able to update the Zynthian via the internet, which doesn,( seem the case using the entry.

This is necessary to enter the :8888 IU-MOD page on which one can play around with the virtual pedalboard, right? I actually manage to get to that part. But I guess this works because this (like the Zynthian web login) logs on to some integrated web-server, thus to the Zynthian alone.
What I want to achieve is connecting the Zynthian to the internet, allowing me to do updates, integrate new plugins and so on.

Thanks Jack, I tried bu for some reason I can’t activate the WIFI (even though the Zynthian detects my LiveBox Router).
Maybe i should plug in a hub between the Zynthian and the PC (I’m using a cable from my PC to the Zynthian right now)

Hi @Vincent

You need to connect the Zynthian to your LAN and it needs to obtain an IP address assigned by your DHCP server which in a normal domestic environment would running on the ADSL modem / router. Once the Zynthian is assigned an IP address by the DHCP server it should be able to connect to the Internet. You should be able to perform Zynthian updates from the Zynthian’s own admin menu. This will prove that your Zynthian has Internet access.

If you connect your PC to the same network as the Zynthian it should be assigned an IP address by the same DHCP router, assuming your PC is configured for DHCP. This should allow connection between your PC and the Zynthian. It is possible that your PC could connect to http://zynthian or http://zynthian.local or http://zynthian.lan but that depends on your PC having a compatible implementation of mDNS or your DHCP server providing appropriate name resolution. If you are able to see the IP address of the Zynthian you can always use that instead of name, e.g.

You mentioned an IP address starting 169. This is given to a network interface when a network is not available and is a non-routable address. It indicates the device has not been allocated an IP address by the DHCP server and may indicate a lack of physical or WiFi connection to the router.

You need to go to the Zynthian webconf WIFI menu and add a network.

It should be clear what to do once you find the correct menu…

If it isn’t, you can ask us.

I wouldn’t worry about the hub, unless you want wired Internat access. In fact for stage use a cable directly between the two is a better option, and then ,perhaps, use wifi to access the rest of the world.

thanks @le51, @wyleu, @riban and @Jtunes (this looks like a royal reception!).
I simply connected the Zynthian to the router, so now it has an IP adress in the same range as the rest of the connected equipments (like my PC).
And I was finally allowed to perform an upgrade (unnecessary but it permitted me to see if the connection was ok etc.)

Still…now I must find out how to actually ‘download’ and/or install new L2V plugins, and mostly the ZenPad ofcourse :heart_eyes:

1 Like

and here’s it actually at the start, just after pressing update software, doing an update from the webconf . . .

and LV2 Plugins … .

I have the same screen, with the L2V’s etc. Does the ZenPad have anything to do with this bit of the interface?:

while now the step sequencer is in the master branch, you’ll get it simply by doing a system upgrade, either from webconf or from the zynthian UI itself (in the admin menu, => bold press on the “back” button)

Happy music with zynthian :smiley:

Thank you so much !!! It’s there !!!

Well where’s our sequence then…?


Oh no, not him :skull: :triumph: :smiling_imp:!!