Waveshare 3.5 b v2

hello, i’ve made my zynthian with a waveshare 3.5b v2, all seem to be work exept , the y axis is inverted. somebody can help me ?
this is my config:
dtoverlay=waveshare35b-v2-overlay:rotate=90,swapxy=1
#dtoverlay=ads7846,cs=1,penirq=17,penirq_pull=2,speed=1000000,keep_vref_on=1,swapxy=1,pmax=255,xohms=60,xmin=200,xmax=3900,ymin=200,ymax=3900


My setup is:
Raspberry pi 3b
I2s pcm 5102
Lastest zyntian version.

1 Like

I had the same problem with my Waveshare 4" MHS and did some experiments with the zynthian UI config (where was it?), but I think I eventually just used the calibration tool from the admin menu. (I may check again, if necessary.)

There is an issue with calibration tool and screen rotation. Usually when someone describes axis inverted the actual issue is rotation of display relative to touch sensor. I have fixed the calibration tool but am offline this week so cannot upload the fix.

Hi @Flourdeau ,
Look at
/etc/X11/xorg.conf or /usr/share/X11/xorg.conf
If there is a 99-calbration.conf, edit the file and try to add

Option " SwapY" “1”

No need to reboot your Zynthian box

systemctl restart zynthian

is enough

If it doesn’t work, you will have to play with TransformationMatrix

Calibration tool has now been updated on testing branch to handle screen / touch rotation. It does not (yet) support single axis reversal which still requires the “SwapX” or “SwapY” option set. I have plans to add an extra cross-hair to detect axis reversal and also to add a method of setting the initial rotation within webconf (which will make it easier to subsequently calibrate the screen) but maybe not today…

Many thx for your advices, but it doesnt work :sweat_smile:
So, i dont use so much the touchscreen function.