Wifi not working out of the box?

Hi Zynthian’er,

I’ve been enjoying my (official) Zynthian very much for the last few weeks, but one thing that has been very stressful is the fact that I can’t get it to join my house Wifi - whenever I try to enable “Wifi”, I get a “failed to open wifi” message, and nothing happens.

I can put it in Ad-Hoc (host) mode, and connect this way - but this doesn’t really allow me to do updates or properly integrate the Zynthian into my studio properly.

I’ve read around some old stale topics that the kernel module might’ve needed to be updated/downgraded - but this doesn’t help much either.

And besides, I can’t be the only one with this issue … and it seems like kind of something you’d notice in the release testing. Any fixes?

Have you tried placing the Zynth close to the router/AP? Maybe it’s just a bad signal.
Try to update over network cable, my fix something.

Moving closer to the router doesn’t help - it appears that Wifi is just not being enabled, or something. I thought I would try to debug this rather than just going for an Ethernet update, but its very weird to me that this doesn’t happen elsewhere …

What software version is running on the Zynth? Maybe it already got sortet out?

Latest image as published on the wiki … also tried the last marked-working nightly build (28-01), same issue.

Anyway I’m going to get ethernet wired up and do an update and see if that changes things. If so, I’d highly recommend the Zynthian devs update the default image so that things aren’t borked, out of the box …

I think there were some improvements to WiFi in updates after the last stable image so you may need to update via wired network before you can get WiFi working. We may be releasing a new image soon and hope this will be fixed in that.

1 Like

Well, I’ve now been stuck in a hell of re-imaging the Zynthian SD card, waiting for it to resize, getting stuck in some reboot loop, and so on … So I’ll be very happy to get the new image to test when its released soon, maybe…

Okay, I installed the latest stable release, and did the “Update” from the menu over ethernet - which seemed to proceed just fine - but its still no go - when I check “[ ] Wifi”, after some seconds of the logo animation I get the message “Cannot start Wifi network!”.

The strange thing is, the “Wifi Hotspot” option works, and I’m able to connect and access the webconf interface. Also, ethernet works fine.

Anyway, I hope you get this resolved because its very inconvenient not being able to add the Zynthian to my studio network without running new ethernet cables … but for now I’ll just run my Zynthian with no network connectivity and manually move it around whenever I need to do an update or enable things with webconf … definitely tiresome, so please devs, look at this bug.

I suggest adding an issue to issue tracker. I am not across the WiFi configuration and don’t use WiFi on any of my devices.

Okay done, thanks for trying to assist me with this anyway:

Have you configured your WIFI lans from the webconf?
WIFI wont work until you have added some WIFI lan from there.

Regards,

1 Like

The procedure is documented in the wiki Configuration Users Guide - ZynthianWiki

I encountered the exact same problem when I started building a custom zynthian a few months ago, though I obviously had added my home wifi network in the webconf. Just retried and it now works. In the meantime I had changed my raspiaudio soundcard for an IQaudio DAC+ (which is supposedly unrelated) and updated the Zynthian software a week or two ago (which is more likely to be related…)

It always works when you “just retry” it. It’s the zynthian way.

Doesn’t work for me- Zynthian just doesn’t seem to want to connect to my wifi, no matter what. Well I guess I’ll just run cable for now …

+1 for no WIFI out of the box, eth ok, updated new installation but just get “Can’t start WIFI network”
I’ve gone into web conf and I can see the wifi networks. It asks to join and I provide a password. I then enable WFFI “on” from the drop down menu, but it fails.
Any suggestions? Other than this it’s working and sounding AMZING!

Does anything rock up in the logs when you enable it and it fails?

To be honest I wouldn’t know where to begin to look?