Zynthian booting from sd card in a raspberry pi 4

Hey together,
i have put zyntian os on sd-card and put it in my Raspberry Pi 4 and startet the PI4, but nothing after 1-2-3 Minutes… in the PI4 there is also PISOUND installed.

Any idea why it is not booting? i should be able to start webbrowser …and then start zynthian

thanks for any idea

I’ve read on wiki that there were some issues with running Zynthian wit Pisound card.
Probably some tweaks are necessary for default image.
I’ve built successfully custom headless kit with RPi 3B and Behringer UMC202HD USB sound card using default image.
I think that at least webconfig should be available without any additional steps.
Are you sure that Zynthian image was burned correctly on your sdcard?
What software have you used?

Hi, thanks for feedback, as i have burned several different images with Etcher on my Windows PC, and all of them worked fine, i suppose this one is also fine.

as booting doesnt show even prompt to put in a command or something else, there might be problem with pisound…do you remember the wiki link?

Just found the link : Unofficial hardware - ZynthianWiki

shit, has anybody an idea how to make it running with pisound?

just found Build with pisound and MCP23017, but how can this work?


Have you configured your hardware from the webconf? You have to connect your zynthian to your network and access the webconf on this URL: http://zynthian.local

Then configure your hardware:

  • soundcard: pisound
  • display: generic HDMI
  • wiring: dummies

It’s explained on the wiki:




great, now it works. didn´t think about that this solution is web-based…
thanks for your help

The SD images are pre-configured for working with the latest official hardware. Any other hardware setup must be configured from the webconf tool.

Rationale: The RBPi is not a PC. Its plug&play possibilities are quite limited and many peripherals can’t be easily detected. Specially those connected to the internal low-level buses (I2C, SPI, I2S, etc).


yes, thanks for details. now i am just wondering that i can´t hear any sound on my headset which is connected to my Raspberry Pi / Pisound…everything configured.
hmmm…will have to study more tomorrow

thanks for any hint

You might look through the Pisound maker’s forum (blokas.io ?) entries for their simple pedalboard project using Patchbox OS.
There were Pi 4 sofware issues with their entirely different system implementation, particularly with the 8Mb Pi.

1 Like

Hey, in case i can´t get it running, i will try but the features of zynthian are exactly what i want, as in patchbox i don´t have the sounds
thanks for your hint.

Hello, just want to inform that zyntian is running with pisound on a raspberry pi4 and a headset connected to jack-connector on pisound! great sound. thanks for all.


I’d normally say :face_with_monocle: at this point and leave it there, but if you could provide a sound sample of you doing something with the zynth we would be grateful.

The monocled icon is a link to a page that describes the overall desire on our part fairly well, and also includes links into how to do recordings …



What @wyleu means is … “come on man, give us some noize!!”
Or as we say on my tow: “Tócate algo, cojones!!!” :grin:

will give you a sound in the next days

1 Like