Zynthian Box with Audio-input (Audioinjector soundcard)


With your line the screen is not responding :confused:

With the double line no problems, it seems that boot config as a max length for the lines …


OK! Good info! :wink:



2 posts were split to a new topic: “Musical-artifacts” for the Zynthian community


I am using this line without any problems

‘DISPLAY_CONFIG’: ‘dtoverlay=waveshare32b:rotate=270,swapxy=1\n’+


i would rather suspect, that either speed=32000000 or fps=25 are your problem.

please try


uhh, this changing of the zynthian.sh file somehow messed my zynthian up…
Official RBPi TouchScreen 7"
I changed as mentioned above it in order to make the inputs of my audioinjector work. None of the effects from mod ui affected the input sound, neither of the mic that I built in nor of the jack input. (But there was input of both directed to the output but unprocessed) But now my Zynthian won’t completely boot anymore after showing the initial zynthian screen even after changing it back. (webconf tool still shows up)
Could somebody maybe send me a zynthian.sh file?

(edit: also after replacing with the zynthian.sh content from github the problem persists.)
so here is some log, I discovered a magic cookie, whatever that means…


root@zynthian:~# /zynthian/zynthian-sys/sbin/zynthian.sh

xauth: timeout in locking authority file /root/.Xauthority
xauth: timeout in locking authority file /root/.Xauthority

X.Org X Server 1.18.4
Release Date: 2016-07-19
X Protocol Version 11, Revision 0
Build Operating System: Linux 4.4.26-v7+ armv7l Raspbian
Current Operating System: Linux zynthian 4.9.35-v7+ #1014 SMP Fri Jun 30 14:47:43 BST 2017 armv7l
Kernel command line: 8250.nr_uarts=1 bcm2708_fb.fbwidth=656 bcm2708_fb.fbheight=416 bcm2708_fb.fbswap=1 vc_mem.mem_base=0x3dc00000 vc_mem.mem_size=0x3f000000 dwc_otg.lpm_enable=0 console=tty1 root=/dev/mmcblk0p2 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait
Build Date: 11 November 2016 11:59:59AM
xorg-server 2:1.18.4-2+rpi1 (https://www.debian.org/support)
Current version of pixman: 0.33.3
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Markers: (–) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: “/var/log/Xorg.0.log”, Time: Mon Oct 16 22:21:21 2017
(==) Using config directory: “/etc/X11/xorg.conf.d”
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
Invalid MIT-MAGIC-COOKIE-1 key
waiting for X server to begin accepting connections .
Invalid MIT-MAGIC-COOKIE-1 key…
Invalid MIT-MAGIC-COOKIE-1 key…

So then my next question for when it will be working again is, how do you activate the audio inputs? Also my alsa mixer looks different than how it’s often shown here in the forum with the level meters and black background and I dont have this L R Capture and Input Mix


@jofemodo @mheidt anybody has a suggestion for this? Im a bit in trouble because I need my Zynthian soon for some concerts. But be nice if you could have a look at the log I posted above. Thanks!


I haven’t seen the magic cookie before. If I would be in your situation I would build it up from scratch. Only soundcard with external hdmi. Etc.
And of course using a fresh image.


Hi @Hampelschwein!

I don’t understand why did you change the “zynthian.sh” …it’s not needed at all, and it will be overwriten by the next update.

You can configure the audioinjector from the webconf tool very easily. And after that, you only need to adjust the alsamixer levels from the command line:

# alsamixer

And that’s all :wink:

But be warned that audioinjector soundcards are quite problematic. IMHO, the 40 pin header is not very reliable …



because it was mentioned here

Enable output and input with alsamixer, as explained by @rod_amaral here Zynthian Box with Audio-input (Audioinjector soundcard)

hm okay I will try to do this when I’m back at home, travelling right now.

could the audioinjector also be the reason why my zynthian still crashed from time to time?


sorry, how exactly do you do this with the command line and the alsamixer?



  1. Login into your Zynthian Box
  2. Run alsamixer:
    # alsamixer
  3. Adjust the levels, enable the right input channel, etc
  4. Quit and reboot. It should maintain your adjustments after booting.



uh shit, I think now I really messed something up. After I put a new image on the sd card I could boot again, then I dropped my backed up “zynthian-my-data” back into the sd card. Then the sound was extremely quiet and distorted and suddenly I couldnt access the zynthian via my computer anymore, then I put a new image on the sd again and now I cant even boot anymore, it gets stuck on the white Zynthian error screen, no access with the terminal possible (“operation timed out”). also the leds at the network cable plug are not blinking anymore. Is my raspberry somehow broken? The soundcard? I’m stuck… I dont want to randomly buy something new


I have bad experiences with AudioInjector soundcards, so i would try to run your zynthian without it. It will show you the Error Screen, but you should be capable of login in.
If it works, try to reconnect the soundcard, and cross your fingers … it’s all i can say :wink:

BTW, I suspect that the 40-pin header included in the AudioInjector is not very reliable and it gives random errors and conflicts. Anyway, a deeper research should be done to being sure of what the problem it is.



ok thank you so far! I suppose the hifiberry is the soundcard you would recommend most?


It works quite well, although there are others that also works fine. I’ve only tested 2 or 3, being the AudioInjector the more problematic, although is the only one having audio input. In fact, currently i have a Zynthian with AudioInjector that works perfectly.



ok, booting again and sound coming out (sometimes), but a lot of weird crashes all the time, I’ll have a look in this…

Meanwhile, the alsamixer. sorry I dont get it what you explained above. Where am writing “# alsamixer”? In the terminal or somewhere in the webconf? Because in the terminal nothing happens


alsamixer is a Linux command. You just type:


followed by the Enter key in the terminal (the # is not to be typed by you, it is just the command-line prompt).

Here’s a tutorial on how to work with sound on a Raspberry Pi (including aslamixer):


ok thanks!
Zynthian is now running halfways stable again! :slight_smile:

the only thing is now, I cant turn the mic off completely, I can make it louder with the mic boost, but at the lowest setting its still on. Is there a setting I’m missing?


It should be possible from the alsamixer. Try to play with the different switches and levels …