Zynthian Box with Audio-input (Audioinjector soundcard)


#21

Mine arrived today, from Amazon, even if I bought it on ebay… maybe a glitch in the Matrix :smiley:


#22

I’ve received 2 cards from Amazon too … i also ordered in Ebay … jajaja!
Perhaps people ordering Zynthian Kits is also receiving it from Amazon? :scream:


#23

Hello !

What is the wiring conf I’ve to set if I want to use the pi tft 2"8 and this audiocard ?
I don’t know if it’s related, but the touch functionnality is not working on my config with this two hats. Screen is working good (except the light of the screen which goes down after the welcome screen Zynthian) but no touchscreen functionnality.

(Screen is not detected as a touch device, no entry in /dev/input/)

Thank You


#24

No wiring modifications are needed for audioinjector. It’s completely compatible with PiTFT 2.8".
Read the main post on this thread :wink:

Regards!


#25

Ok, thank You for the reply !

I’m asking myself if I received the right pitft … :confused:

On the PCB i’ve the label “ft6202” do You have the same ?

Thank You Jofemodo !


#26

Could you send some more detailed photo of the display? And the exact model name … please!
Anyway, it seems that this is not the “normal” PiTFT 2.8" we normally use for Zynthian :wink:

Thanks!


#27

It’s the capacitive model I think :

I’ve just install the kernel from adafruit (https://learn.adafruit.com/adafruit-2-8-pitft-capacitive-touch/easy-install)

And i’ts ok now, I was thinking you added the kernel for that screen, but seems not !

I can now full test Zynthian, just have to add the midi input for future clock-sync with my korg emx1.


#28

Hi @mrlsk!

It shouldn’t be needed to install the Adafruit kernel. Doing so can break something, specially MIDI input.

Probably your display is already supported by standard kernels, but you have to load the corresponding layout in the /boot/config.txt. Sometimes you have to copy a specific layout file from the manufacturer (Adafruit).
Also, you should have to adjust the touch calibration. If you do so, you can give feedback, so we can add your display to the webconf tool.

Regarding MIDI sync … currently it’s not implemented in Zynthian, or to be more exact, AFAIK any of the sound engines integrated in Zynthian currently support it ;-(

Kind Regards!


#29

@mrlsk, @jofemodo

See (MIDI)Sync of engines/plugins?.

Perhaps starting jack_midi_clock on zynthian may sync external devices to jack-midi.

Regards, Holger


#30

Hi !

Oh Ok, with my keyboard it’s still working (usb).

Ok I understand, I can restart from scratch to test a new layout.
Yeah ok I will try to find the informations.

And for midi sync I know, I’ve read the thread on that topic :slight_smile:

Thank You !


#31

I’ve search and i found that my screen is the 2423 :

| Ada# | Name | Size | Pixels | Touchscreen | Backlight | Header |
| 2423 | PiTFT Plus | 2.8" | 320x240 | Capacitive | variable | 40-pin |

I Think this is that setting for my screen :

Section "InputClass"
Identifier "captouch"
MatchProduct "ft6x06_ts"
Option “SwapAxes” "1"
Option “InvertY” "1"
Option “Calibration” "0 320 0 240"
EndSection

And that module

sudo nano /etc/modules
and add ft6x06_ts on a line at the end

I will try after a fresh install !


New feature: X-Y touch-controller
#32

Hello ! sorry for the off topic but it’s OK now, the config file as to be not too long for each line.

It seems that separate line is working :

dtoverlay=pitft28-capacitive,speed=32000000,fps=25
dtoverlay=pitft28-capacitive,touch-swapxy,touch-invx

But not when there is only one line config (too long)

I can now full test the engines, realy cool, I will post a video :wink:


Replace the resistive against a capacitive touch?
#33

I’m not too sure of RBPi “boot/config.txt” syntax , but perhaps it would be better to try like this:

dtoverlay=pitft28-capacitive,speed=32000000,fps=25,touch-swapxy,touch-invx

Regards!


#34

With your line the screen is not responding :confused:

With the double line no problems, it seems that boot config as a max length for the lines …


#35

OK! Good info! :wink:

Regads!


#36

2 posts were split to a new topic: “Musical-artifacts” for the Zynthian community


#37

I am using this line without any problems

‘DISPLAY_CONFIG’: ‘dtoverlay=waveshare32b:rotate=270,swapxy=1\n’+
‘dtoverlay=ads7846,cs=1,penirq=17,penirq_pull=2,speed=1000000,keep_vref_on=1,swapxy=0,pmax=255,xohms=60,xmin=200,xmax=3900,ymin=200,ymax=3900’


#38

i would rather suspect, that either speed=32000000 or fps=25 are your problem.

please try
dtoverlay=pitft28-capacitive,speed=32000000,touch-swapxy,touch-invx
and
dtoverlay=pitft28-capacitive,fps=25,touch-swapxy,touch-invx


#39

hey,
uhh, this changing of the zynthian.sh file somehow messed my zynthian up…
Official RBPi TouchScreen 7"
I changed as mentioned above it in order to make the inputs of my audioinjector work. None of the effects from mod ui affected the input sound, neither of the mic that I built in nor of the jack input. (But there was input of both directed to the output but unprocessed) But now my Zynthian won’t completely boot anymore after showing the initial zynthian screen even after changing it back. (webconf tool still shows up)
Could somebody maybe send me a zynthian.sh file?

(edit: also after replacing with the zynthian.sh content from github the problem persists.)
so here is some log, I discovered a magic cookie, whatever that means…

Summary

root@zynthian:~# /zynthian/zynthian-sys/sbin/zynthian.sh

xauth: timeout in locking authority file /root/.Xauthority
xauth: timeout in locking authority file /root/.Xauthority

X.Org X Server 1.18.4
Release Date: 2016-07-19
X Protocol Version 11, Revision 0
Build Operating System: Linux 4.4.26-v7+ armv7l Raspbian
Current Operating System: Linux zynthian 4.9.35-v7+ #1014 SMP Fri Jun 30 14:47:43 BST 2017 armv7l
Kernel command line: 8250.nr_uarts=1 bcm2708_fb.fbwidth=656 bcm2708_fb.fbheight=416 bcm2708_fb.fbswap=1 vc_mem.mem_base=0x3dc00000 vc_mem.mem_size=0x3f000000 dwc_otg.lpm_enable=0 console=tty1 root=/dev/mmcblk0p2 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait
Build Date: 11 November 2016 11:59:59AM
xorg-server 2:1.18.4-2+rpi1 (https://www.debian.org/support)
Current version of pixman: 0.33.3
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Markers: (–) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: “/var/log/Xorg.0.log”, Time: Mon Oct 16 22:21:21 2017
(==) Using config directory: “/etc/X11/xorg.conf.d”
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
Invalid MIT-MAGIC-COOKIE-1 key
waiting for X server to begin accepting connections .
Invalid MIT-MAGIC-COOKIE-1 key…
Invalid MIT-MAGIC-COOKIE-1 key…

So then my next question for when it will be working again is, how do you activate the audio inputs? Also my alsa mixer looks different than how it’s often shown here in the forum with the level meters and black background and I dont have this L R Capture and Input Mix


#40

@jofemodo @mheidt anybody has a suggestion for this? Im a bit in trouble because I need my Zynthian soon for some concerts. But be nice if you could have a look at the log I posted above. Thanks!