Zynthian no-Wifi, RTP MIDI & TouchOSC Bridge (Strange behaviour)

I am not able to get my Zynthian working as a Network device nor does it allow me to activate the Wifi, so I could use the OSC Bridge. RTP MIDI is activated and shows up in my network MIDI setting on my Mac, but gets kicked out after a few seconds.

Screenshot 2022-12-16 at 15.19.40

There is only one way I can get it to work with my DAW by connecting a USB MIDI hub.
I tried everything to activate Wifi and it gives back an Error, which I reported in the Wifi issue topic here in the forum.
RTP-MIDI is activated and it shows up, but as you can see on my screenshot something causes it to get kicked out. I did deactivate the Firewall to see if it may cause that issue, but no changes.

What the weird thing is:
OSC Bridge is activated and on my Mac as well. I also use an iPad with TouchOSC and since Wifi is not working I tried to connect the iPad via USB to the Zynthian, but the Zynthian does not show up as a device.
When I connect my iPad via USB to the Mac and the Mac has the OSCBridge active, then the iPad shows me the Zynthian, so via this extra, I can actually OSC control the Zynthian with my iPad.
It is very confusing and I can’t find a way to get any further with this issue.

So, again: OSC Bridge is on, wifi does not want to activate, USB does not show Zynthian as OSC host/device and when I add the RTP MIDI connection to the MIDI network it gets kicked out within seconds.

Help would be appreciated.

A temporary workaround to the RTP MIDI problem (and a connected issue) is described here:

I have no luck with the suggested setting.
I also can’t find a way to “disable” IPv6 on my Mac. The options are Automatic, Manually, Link-local only…

I keep getting the same error message from the MIDI Network setting after activating Zynthian in the Network, as you can see on the screenshots I shared above.

It tells me, that my firewall or router setting should be checked. The firewall is off and there is no router. I am connecting directly to my Mac via LAN.

Well, Zynthian works with my USB MIDI hub (emagic MT4) and it does the job, but I would really love to use my TouchOSC controller on my iPad.

I just discovered something a bit confusing.
In the Zynthian config MIDI Options, it shows that the OSC IN Bridges are on the out channels and at the In channels there is the OSC Out Bridge…
That doesn’t sound right.

When I activated the OSC Bridge on my Mac, which is connected via LAN and my iPad TouchOSC connected via USB to the Mac, then I see the Zynthian in the OSC connections on my iPad, but not when the iPad is connected directly to the Zynthian via USB.
Wifi on the Zynthian doesn’t work anyways…

Found a solution for controlling Zynthian via LAN.

the RTPMidi which automatically showed up in the MIDI network settings is not working.
So, I just added manually the Zynthian IP (port 5004 was already correct) and now it works.
@wanthalf it had nothing to do with IPv6 settings…

So… at least this problem is solved now. Still no TouchOSC - OSCBridge connection possible.

That is a solution as well, of course. If you set a fixed IPv4 address, MacOS won’t try the automatically resolved IPv6 (as it obviously does by default) so it won’t fail. But you need to have a static IP address assigned to your zynthian.

“Disabling” IPv6 can be done e.g. just by setting IPv6 to “manual” configuration and not configuring it at all (that is how it appears in the latest MacOS, at least). But your solution is surely better in your case, as it seems your machine actually uses IPv6 for real connection otherwise. In my case, there was just some autoconfigured local IPv6 for local network, but not for internet connection, so it is of no real use anyway.

1 Like

Hi @Eule !

IN and OUT are relative concepts.
The output signal from an electric guitar is the input signal for the amplifier.
The OSC Bridge output is what you would call input from your point of view. I mean, the MIDI events going out from the OSC Bridge are MIDI input for the zynthian engines. In the other hand, the MIDI events going out from the zynthian engines are MIDI input for the OSC Bridge.

I know, it can be confusing :sweat_smile:

Regards

1 Like

I am not at all confused about these concepts :wink: I am a producer since the end of 80’s and from the perspective of the Zynthian the OSCBridge Out is going out and into my IN OSC on my iPad.
Outs are outs and ins are ins :wink:
Anyways… they are activated and they show up on my Mac mini as I explained above.
But, I am not able to connect to the OSCBridge on the Zynthian directly via iPad (neither via USB nor Wifi) It just won’t show up.
I find this interesting, that the LAN only seems to establish the OSC connection on my Mac and funny enough when I connect my iPad via USB to the Mac, than I see the Zynthian.
I am not sure why the USB connection doesn’t work on the Zynthian. The Wifi issue is of course related to the not-working Wifi.
Maybe that problem gets solved in the moment the Wifi works.

I did change the country code in the wifi config file on the zynthian. It was set to ES (Spain) and I am located in Germany.
Whenever this will work one day, I wonder if I always need to change that country code in case I would travel with the Zynthian to another country. That would be a bit strange.

Right now I am happy with the stability of the Zynthian. It is working well since I discovered the error, which caused the audio dropouts.
Connecting the TouchOSC of my iPad is something I really want to figure out, but I can handle it like this for the moment.

In the other forum about the Wifi issue, some users posted the issue was added to Github to the things to-do list. Let’s see when this gets solved.
I am just wondering how many other users run into this problem. Maybe not so many who use Wifi.

Anyway, you guys do a brilliant job and the new version with the audio mixer is much better already. more responsive. I noticed that the audio signals are moving with some latency, but I can live with that. The audio itself has no noticeable latency when I use an external MIDI keyboard or the DAW.
I am looking forward to seeing the further development of this project. I am happy I discovered it.
I do use only the software and I am aware this doesn’t support you guys financially.
So, at least I can try to help by pointing out issues and doing the best I can to find out what causes it.
At least this way it will help you to pinpoint the cause and fix it.

I will also use the Zynthian in the future for my live sets and I am thinking of making some videos on Instagram and Youtube. Some little live sessions. I guess this will help motivate others to buy a Zynthian.

I explained a couple of times, that I have a very particular use for the machines I am working with because I tune my music and need very precise settings for Tempo and Master Tuning.
When the Zynthian let me down I was looking for alternatives and was thinking to buy a Waldorf blofeld. It also has multiple layers and seems a fine little machine.
But then I decided to look into the Zynthian again and see what had chanced in the past year, so now it is working pretty much the way I need it to work and I am happy.