Zynthian with 3rd party devices

Hi Zythianiacs,
I try to build a zynthian with a Raspi 3B+, a Behriger UCA 222, a 5" Display (GPIO/HDMI), without Encoders (Dummies) and with a rapoo-Mouse and Keysonic Keyboard.
I am using the zynthian_gorgona_omega_rbpi3_kitv2-2018-04-03.

After tweaking the hardware in the webconf tool and launching the system my display is blinking and asking for logIn. How can I stop the blinking, because I can´t finish this step?

I tried to use ssd, but I do not know, how to start zynthian via ssd. Perhaps there is a tutorial or so?


Hi Norbert,
as explained you will find tzhe solution in this thread.

1 Like

It can be multiple USB DEVICES…
some say power supply others differ… :stuck_out_tongue_winking_eye:

I tried to start the vncserver.
Now I have a new terminal and I can insert my logIn.


And so I need a tutorial or a manual for the next steps.

Hi Roman,
I tried the vncserver. I think, it´s the same !?

Hi wyleu,
I use an ipad-usb-device with 10W (5V/2A).
Isn´t it enough?

I would say the general feeling is a little bit more (3A) is better . . .
But the UI-log is a great place to get an idea of how well the machine is working…

Point your browser at zynthian.local or the ip address. the zynthian does try pretty hard to tell you the ip address it thinks it’s on.


There is a page where you find how to start the ui from the console

Hi everybody, I’m back again.
Now I have a raspi 4 and I try to build my own thing.

My hardware: raspi 4, raspbian, 7"touch-monitor, behringer UCA222, bluetooth-keyboard and mouse.

My status: I’m using jack (qjackctl), I can run vlc, audacity and fluidsynth. Wonderful, because with my kb (Novation Impulse) I can send up to 4 Channels and so I can buildt splits and layers. And using audacity I can record something. At this moment just a new stereo-track while a playback is running. But the important thing for me is, that I can mix an external signal with the zynthian-sound. wonderful!

My wishes:
I want to install

  • setBfree (I don’t find a tutorial how to install) and
  • linuxsampler (the same). And I need a workflow that shows me, how organize selfmade samples and how to store it on the sd or on a usb-stick.

Please excuse my bad english. I’ll do my very best.
Raspi4 rules :+1::nerd_face::boom:

1 Like

Hi @Micki!

Gorgona images are not supported never more.
You should be using the last official SD image “Aruk RC-3”:



Excuse, i see you are using RBPi 4 in your last setup. Then you should be using the experimental SD-image “Aruk Buster”:


1 Like

Hi Jofemodo,

thanx for your answer.
You´re right. I´m using both.

The Raspi 3 with Zynthian-Soft- and Hardware.
With that I try to understand how to combine it with my keyboards. I see a lot of possibilities.
But I think it´s only a temporary solution.

The Raspi 4 works simpler, I believe.
I had no problem to start audacity, qjackctl and fluidsynth.
But now I need help to add setBfree and Linuxsampler.

Do you have an idea?

Best Regards

But … are you using the Zynthian images?
Linuxsampler & setBfree are installed by default …

Yes, on Raspi4 I use 2019-07-10-raspbian-buster-full.img.

e.g. setBfree:
the folder home/lv2 is empty I tried to run “setBfree” with the run command. No result.

I´ve seen yours is another image.
I will download it and will answer later.
Thanx again !

No my friend. Raspbian Buster is not Zynthian. You have to use the official Zynthian SD image … or build your own image.

Yes I know, that raspbian buster is not zynthian.
But in this forum we are talking abour 3rd party devices.

Till today I could not run a zynthian image on the raspi4 and so I tried this way.
One of my most importend feature is to mix an external signal with setBfree or Linuxsampler-sound. That´s the reason I want to use the behringer uca222.

If this target is working with zynthian I would be very glad.

So, 2 hours later:
I´ve made a sd with the official Zynthian image and put it in my
Raspi 4 with 4 GB and
7" display and
Behringer UCA 222.

I´ve started the webconftool.
it recognized the Raspi4. But all the other points were wrong and I couln´t change it.

Did you select the custom option …?

1 Like