ZynthianOS: the upcoming Zynthian SD image


#1

As probably you already know, @guysoft has been working hard for bringing to the zynthian community an automated system for building daily SD images. We are going towards “continuous integration” … woaooooo!! I’m really excited with it!!

The ZynthianOS images are based in the @guysoft’s CustomPiOS building system and it’s built on top of the latest raspbian stretch distribution. We use Jenkins too …

As we have solved most of the problems related with the building process, it’s time to open the thing. ZynthianOS is not the official SD image yet, but it will be very soon, so we need your help for testing it.

You can access the Jenkins Workspace for downloading the latest image:

http://os.zynthian.org:8080/job/ZynthianOS/ws/

These experimental images are not CPU-optimized and should run in RBPi2 and RBPi-Zero too, although i’ve not tested yet. Some feedback about this subject would be very appreciated.

Currently the images don’t include any soundfont, but this will be solved very soon. Also, we hope to start releasing optimized images for RBPi3/RBPi2 and also images including RT-kernels. Stay tuned.

We are making a huge step with the new building system!!

Thanks a lot, @guysoft!!

P.S: Ahhh!! The new ZynthianOS image is configured as WIFI access-point by default … just look for the “zynthianos” SSID in the network list from your PC. The password is “raspberry” :wink:


New Zynthian build from kit -- No sound, wifi doesn't work
New Zynthian build from kit -- No sound, wifi doesn't work
#2

Wow, @jofemodo and @guysoft! That’s absolute crazy!!! I tried to get buildroot running for this task some month ago - it was a nightmare. So I hope I can find some time the next days to check this. Download is started.

Regards, Holger


#3

Warning! Many MOD-UI patches included in the image doesn’t work and will break the zynthian UI. It’s due to changes in the LV2 URIs. This patches have to be re-made …

Regards,


#4

Wow! \o/ Great news =)


#5

Downloading it!
Have I to be carefull with some engines in particular?
Is there some engines you want to be tried first?
MOD UI is OK to try? you talked about some freeze, just have to restart UI?

Just tell me if you want returns for a particular engine!

Amically

Tehef


#6

Today I spent a few hours trying to run it on a pi zero w. I’m using a pHAT DAC and a generic hdma monitor. Wiring set to dummies. I keep getting the Zynthian “Error” screen. Wifi broadcasts zynthianos and I have to enter the password two times before I can connect my iPhone to the network. Zynthian.local will not connect and times out. Prior to trying the Zero, I put the same sd card in a Rpi3 using the same configuration settings and same pHAT DAC and monitor. It boots and displays the Zynthian gui with no “Error” screen.The rpi3 broadcasts zynthianos and I can connect to the Zynthian configuration tool. I haven’t tested out all functions on the rpi3, but most of the things I’ve tried worked. As you mentioned sound fonts are missing and Mod Ui needs work. I tried to load the Pure Data Engine but it gets stuck in an endless loop and freezes the system. I will continue with further tests in the next few days to see if I can get Zynthian working on the Zero W.


Zynthian as Wifi Hotspot
#7

Yay,

Also - I’d suggest having the last two weeks available for download. It means if the last few builds fail there is still a usable nightly image.

BTW - I have started adding in CustomPiOS the option to export files from the build. This means I can export a realtimekernel.tar.gz . So we could have an image that can switch between the realtime kernel and a normal kernel.


#8

How can i configure the Jenkins Workspace for doing that?

That will be very convenient. In that way using RT kernel could be a configuration option, so users could choose between latency or performance :nerd_face:

Regards,


#9

Just tell me what it needs and I build a switch in the webconf


#10

Just copy the files to a public web folder, the Jenkins workspace is not best toto sharw from.
Example: http://unofficialpi.org/Distros/ZynthianOS/nightly/ (don’t use this, but you can take the apache theme).
Then add a Jenkins job that removes files older than two weeks.


#11

OK! I already added a cron tab for deleting images older than 1 week. Server disk is only 100GB and image size will grow up when i add some sound fonts.

Thanks!


#12

Ok, RealtimePi nightly, which uses the same image as Zynthian, now also exports the realtime kernel.

Latest nightly at: http://unofficialpi.org/Distros/RealtimePi/nightly/

So in a zynthian build you can do:

Don’t do this unless your are ok with perhaps bricking that zynthian build!

cd /
sudo wget http://unofficialpi.org/Distros/RealtimePi/nightly/2018-06-12_realtimepi-kernel-4.14.34.tar.gz
sudo tar xzf 2018-06-12_realtimepi-kernel-4.14.34.tar.gz

(Kernel works for both Rpi2, Rpi3 and zero)

Technically if you back up the kernel files and have them in a tar.gz, you could extract the kernel you need.

Another way is to give this kernel a different name and then in config.txt change to kernel=foo.bar. And it might need to handle different Pis.


#13

We need it both kernels as different files and two bash scripts that are copying either one to the real location/name. I can build the switch in webconf.


#14

Well script 1:

sudo tar xzf 2018-06-12_realtimepi-kernel-4.14.34.tar.gz --directory=/

You can also extract the gz and only tar xf for speed

And the original kernel can be obtained by:

cd /tmp
wget http://unofficialpi.org/Distros/RealtimePi/nightly/2018-06-12_realtimepi-kernel-4.14.34.tar.gz

echo "" > /tmp/kernel_list
for i in $(tar zvft 2018-06-12_realtimepi-kernel-4.14.34.tar.gz  | awk '{ print $6 }'); do if [ -f /"$i" ]; then echo /"$i" >> /tmp/kernel_list; fi; done
tar czf current_kernel.tar.gz --files-from=/tmp/kernel_list

And then you can

Script 2:

sudo tar xzf current_kernel.tar.gz --directory=/

#15

Both kernels have to be in the build.

We can’t assume that the user is connected to the net when he or she wants to change it.

@jofemodo, pls provide the architecture for this feature.

Mittwoch, 13 Juni 2018, 01:39nachm. +02:00 von Guy Sheffer discourse@zynthian.org:


#16

OK! Let me try a little bit :wink:


#17

Hello guys!

I installed ZynthianOS today, but I’m having trouble accessing Zynthian via SSH. Even connected to the zynthian network (wifi-hotspot) I can not access the zynthian.

Another question, how can I enable and disable the hotspot?

Regards, Rod

ssh