5 Midi devices connected, only one is working


I’m working on a project involving 5 arduinos (Due using midiUSB lib). I thing I’m close to get it work but I’m stuck with wich seems to be a little problem of software/configuration. I tried to fix it up for ages now but I think it’s time to surrender. I’m pretty sure that one of you knows the answer…

Basically, the 5 arduinos share the same code (I thought about some kind of Midi device ID ?).
I get a splashscreen error so I have to connect arduinos after zynthian boots up.
Only on arduino board seems to be “listened” by zynthian.
The weird part is that pianotech demo is working fine, I can play notes from everyone of them…

Any clue ?

Thank you !!!

Is that 5 physical midi connections? Hubs ? Lot’s of context will help.

How does it behave with only one arduino connected.?

Does the machine pass the test set…? :joy:

Thanks for the answer !
this is midi over USB so 5 physical USB plugs, and obviously, you’re right, I use USB hubs…
Those are part of the problem, I guess, but that’s really weird that it works with a pianoteq layer and it doesn’t work with the others…

I forgot one important thing and I appologize : I have to separate arduino power and raspberry power (by cutting power wire). that may prevent hubs to work well, but that doesn’t explain why pianoteq layer works !
I really need at least one two ports hub. I hope that is not a non working configuration with zynthian…

Actually Messy bench pictures can be REALLY useful !!!

I tried different configuration and it appears that I get and error if two or more devices are connected to the hub.

1 Like

If you are using an old Gorgona, Pianoteq is probably receiving all channels while layers with other engines only receive the layer assigned. This is fixed in recent updates and new Aruk SD.

Have you tried the MIDI monitor from the webconf tool? :wink:


The image I’ve used is 4 or 5 monthes old now. So, in your opinion, the latest release should fix it up ?
Good idea for the webconf tool I’ll give it a try tomorrow.
Thank you !

That is circuit twisting at it’s chaotic best !

I’ve seen gigs played on kit like this !!

I can’t choose between the three screws holding the encoder plate in or the tie wrap round the display…!!!

What on earth is it mounted on and what are you doing with it…?

Is it a harp?

I was also about to sing the praises of the webconf MIDI Log.

I don’t remember any discussion about USB hubs but I’ve had a long standing issue with multiple MIDI USB devices but always been told it’s Power supply related. Personally I’m not so sure about that.

I reckon we should get one audio recording, at least…:face_with_monocle: There looks to be all the necessary bits of zynthian to get a sound file to us…

If only I could link to the new wiki entry with some form of anchor like this… :smiley:

I warned you about the chaos :laughing: !!!

Well done, it’s a harp, yes !

So do I about the power : As there is no power supplied by the raspberry, it can’t be power related.

You have several Arduino units, each acting as a USB MIDI interface? There is an issue #81 which describes problems starting Zynthian with multiple USB interfaces connected. Try starting up with one device connected then add others after Zynthian is running. If this works then we may need to review #81. Also, update to Aruk release.

Well we are obviously going to require a picture of the whole device before we can go any further… :smiley:

A diagram would also probably help. I tend to use Inkscape (these tutorials are really good ) cos I’m keen on SVG at the moment, but many, many alternatives are available.


I moved to Aruk. Very promising, but it’s getting worse :sweat_smile:

I still get the problem with usb devices : Zynthian doesn’t boot (i get a black screen instead of the error spalshscreen). Unfortunately, I haven’t got enough time to investigate more (the truth is : I have a wife :smile:). So I give up on this problem for the moment as everything works ok if I plug usb devices after the boot.
May main problem now is that Pianoteq doesn’t work anymore ! No fancy electronic for the test : only a zynthian v2 and one USB master keyboard. It works with synthetiser, SF2, etc. layers. But when I create a Pianoteq layer, it seems like the layer is not really activated : I can see the blue “m” (received midi message, I guess. Very usefull) at the top right of the sreen, but the vu meter doesn’t show anything. In fact it acts exactly the same when you play a note without any layers created…

I don’t if it’s a RC bug or if I’m getting more and more stupid !

Hi @Djihatch

I have the same problem with boot

I use two arduino MIDI / USB controllers.

When only one is connected, zynthian starts normally, but with the two connected on the usb port the initialization fails and only the black screen appears.

I will try to extract the logs from the boot to try to verify what is happening.

You can read all about it here. Basically JACK2 require an audio card to provide its clock timing but we currently pass the first ALSA card to JACK2 which may be MIDI only. The ordering of the ALSA cards is a little random so sometimes it might work and sometimes it may fail but generally, if you have USB MIDI devices plugged in at boot then it is likely to fail to start JACK2 which is a dependency for Zynthian. (No audio - no Zynthian.) Now that we have a good handle on the cause of this there are a range of solutions which are being considered. We should be able to resolve this soon but until then the work-around is to unplug USB MIDI devices before booting Zynthian.

1 Like

Uhem, could be a solution.

This problem is present in Zynthian from the first prototype (and it’s in my list from then!). You can boot with 1 USB-MIDI device plugged-in and it will work. But, if you boot with 2 USB-MIDI devices plugged-in, it will fail. I’ve tried to solve it a few times, but with no luck. Anyway, i will try again with the fresh info i have now … :wink:


Thanks riban, wuleu and jofemodo for this clarification,
At least I know that it’s a known issue and I hope that there will be a fix for this. If not, plan to let every usb devices plugged and add a delay to power them.

Any clue about my Pianoteq problem ? I don’t know if I have to open a new thread or post this issue in the RC2 thread… Anyone can repeat the issue (no sound with a master usb keyboard with pianoteq layer while every other synthetisers or sf2 players are working) ?

Thanks !

I had the same issue yesterday with a fresh image and the pianteq demo version.
I didn’t look into it either…maybe the 6.0 demo is too old and we should ship a new one?

Too bad for me…
I moved from gorgona because synths and SF2 player didn’t work, pianoteq was ok.
Now, Pianoteq doesn’t work anymore but SF2 and synth layers work !

I’m cursed !!! :joy:


yes, 6.0 is too old: