Error on boot screen [SOLVED]


#1

Hello Folks,

I’am new with Zynthian has build one on a RP3B+ with 3.5 LCD and audioinjector soundcard. I’ve set up a fresh SD-Card with the build . …2018-04-03 . When the RP boots he show me first Zynthian screen, then after few minutes he run into a Zynthian screen with red letter ERROR. I can’t connect to the RP until now. Any idea? Can I boot without the soundcard, I 've tried it but same result. I boot with any except the lcd, same result. Any hint is welcome.
I use WIN10 to connect to RP
Greetings Roman

(Sorry German english)


#2

Please show us a screenshot of the webconf dashboard.


#3

You should be able of connecting to the Zynthian, to the webconf and also by SSH.
As you are using windows, probably you can’t use the “zynthian.local” link-local domain name and you will need the zynthian IP.

Check the wiki …

Regards,


#4

I ve tried to connect to the rp as described in the Wiki. I used arp -a no responce. Tommorow i will try angryport scanner. Thanks so far


#5

Is it the right image noticed in the Wiki? Gorgona omega… 2018-04-03?


#6

Good Morning,

I checked the boot prozess by connecting the hdmi out and found that no IP adress is set?

See enclosed picture.


#7

After install a night build image [ ] 2019-03-01-zynthianos-stretch-lite-1.0.0 I can connect to Zynthian.
Now I have to find out how I should connect to a static network address.

Resume: It’s a nightmare if you look into the world by (a) Windows .

Thanks Roman

(May be it could be added to the wiki that you can as windows user check the IP address by HDMI out.)


#8

Obvious;y if you have got the GUI running then the details are in the admin section under Network Info
Yes finding the IP address in such a situation can be a bit of a pain… the .local name space is certainly a partial solution but I’ve found it to be involved to set up on Windows and I’ve not managed to get it working on Android.

Getting a mechanism to reliably ( and that really is the issue) dump out the IP address requires a fairly wide knowledge of the possible failure modes and given the possible hardware configurations we are dealing with it’s probably better that we concentrate the limited resource on other areas because I can vouch for the fact that once you have got a log on you forget very quickly about the ip address issue and just get on with stuff…

The router connected to the zynth often has an interface that will let you see the ip address and that is how I have discovered particularly shy zynth’s and then off course there is the ping command which will allow you to examine the local name space, but I would get yourself onto named addresses (zynthian.local) as quickly as possible because it really is the most repeatable approach especially in the DHCP world that most local routers live in and it’s a bit deflating to have to play hunt the ip after a brief network re allocation.

Windows names . . .

If anyone has a way of getting names to work on android browsers I’d be very happy…

the Service browser app reveals the _workstation._tcp details which helps but the browsers resolutely refuse to resolve the address…


#9

So far I could enter the WebconfUI, unfortunately I can’t update the advanced network settings. I added a network and want set the PSK. I got error 500 after press the save button. I also can’t connect via ssh (using Putty):

Network error: Software caused connection abort.

Any Idea?

What the last night build which is running?

Greeting
Roman


#10

I wouldn’t worry too much about the build they generally work pretty well from my experience. The problems normally come from jack starting up with the wrong config set up for which you need the webconf … .
Once you have that right things ( by enlarge) works pretty much as expected.

So you do actually see the webconf? could you upload a screen shot of the home page…?


#11

Have you updated twice already?


#12

Hi Folks,

I do the same mistake as all people running in trouble with the first boot.
I solve the problems if I set up an upper address area of my router for DHCP (I hate to do so), never the less it’s works. The most importend mistake was that I did’nt connect to the router after upset the DHCP. The WebconfUI works slighly ,without the WIFI setup. But I could run software update, twice :wink: . The audio test pass with brazil rhythmen.
I furtherwise can’t reach the zynthian box via ssh (see post before).
I will stop for the moment and going to other importend thing. I’ll come back if I have time.
Greetings
Roman


#13

Rgd putty, I guess you need to regenerate the keys. There is a button available in the webconf


#14

If you are using a “nightly build” ZynthianOS image, you don’t need to update twice, moreover if you are using a recent one :wink:

Regards,


#15

I’m thinking that writing the IP address in the error screen could be good idea … :wink:

Regards,


#16

Maybe it is better to write in the wiki that a DHCP is nessary and connecting to this router before you boot the first time.

Thanks


#17

A DHCP is always needed my friend, unless you configure the IPs by hand, what is quite rare at present time. AFAIK, DHCP is enabled in most of networks. I can’t remember the last time i connected to a network without DHCP. Mid 90’s or so …

Anyway, you are right and it should be documented on the wiki. And the Zynthian’s IP should be shown in error screen too :wink:

Cheers!


#18

Ahhh! Of course …
You are using an experimental “ZynthianOS” image that have a “Wifi Access Point” enabled by default. That’s not documented yet … but will be. If you have not configured your Wifi network, simply take a look to the list of Wifi Networks from your computer. Zynthian should be there …

Using this, you can access the zynthian without router or cable, although can’t update, of course, as no Internet Gateway …

Regards,


#19

Hi all,

it’s solved. All points are fulfilled, by a help of you. Thanks a lot.

What have I done:
Using a DHCP is nessaery (I am older and used to use static IP)
Setup a fresh Gorgona Omega image on a SD card.
Connect to your Router before you power on your system first time (if you interrupt or restart before the updates are completed, is save to set up a fresh image).
Start the WebConfUI, the IP is shown in your router network list.
Select the correct hardware.
Do a software update ,selected on your Zynthian (There is no point in the WebConfUI first time)
Do a software update again.
Connect to your WebConfUI and regenerate a key, after this you are able to connect via ssh.

That’s all, but a lot of patience is needed.

Thanks again to all

Regards
Roman


#20

Congratulations … and sorry for the inconveniences!! A new SD image is coming and i hope everything will be easier then. BTW, the error screen showing the IP is already implemented :wink:

Kind Regards,