Is it possible to try out zynthian with just a raspberry pi (and a hifi hat)?

Like the headline says. Since I’ve already got a rpi 3, a midi keyboard and a hifi hat, would it be possible to try out zynthian just using this?

You also need a display. It can be a HDMI one …

Once you have burned the SD-card, boot the zynthian, wait until it finish the “first-boot” procedure and configure your hardware using a web browser. In the wiki you can find detailed instructions …

Mr. @wyleu is an expert in that subject, so i’m pretty sure he will give you some tips :wink:



Depends on wether or not the MIDI keyboard is 5 pin MIDI or USB . . .
If the latter then fine, if the former you wil need a zynth MIDI port which is either a USB -> MIDI device ( many out there, some horrible) or a zynthian encoder board populated for MIDI In.

An hdmi monitor is definitely handy ( for finding out the IP address if nothing else) and a wired Ethernet connection is fairly essential ( till you’ve turned on wifi ) and a browser to look on something on the network to examine and configure via the webconf (zynthian.local password raspberry)


Thank you for your responses. Yes, got a hdmi monitor a network cable and an USB midi keyboard. How big does the sd card need to be by the way?

I’ve just rebuilt my zynthian-amp.local machine on a Pi3B+ on a 16G card, the image was about 12G so a bit of spare space.

I didn’t mention it but select Dummies for encoders . . …

1 Like

I guess you’ll need a mouse too if you don’t have encoders or a touch screen.


I made the mistake of not making it easy to connect a wired Ethernet cable without dismantling half of the Zynthian first. But that’s ok, as you can write a little file in the SD card using your computer after burning the image - you’ll see a drive called boot. In this file (wpa_supplicant.conf) you set your wifi network and password. Then on first boot, you’ll maybe need to turn on the wifi on the admin options. I followed the instructions in, and they have worked many times for me, now!

1 Like

I managed to get it up and running with the hifi hat at first. It had some nasty cutoffs or something. Not sure what it was. Anyways, I added a powered external usb card. At first it wouldn’t show me the control screen. I got it up running after a few reboots however. Not sure why that worked, but oh well. Sound was perfect with that thing. Anyways, I have a couple of questions: Are there any images that are capable of running on the pi 4 yet? Secondly, can you split the midi keyboard, so that you play base guitar with your left hand and say piano with your right hand with Zynthian? Thirdly, can you (prefearably easily) set knobs and sliders on a midi keyboard to do stuff, like increase and decrease volum, add and remove effects, etc?

1 Like

Absolutely! All “Buster” images can run on the Pi 4. I use Buster RC1, available in the Zynthian Wiki.

I think people are working on that. Try this topic:

This Wiki article explains setting knobs and sliders to do stuff, and this Wiki article explains adding/removing effects.

Hope that helps!


I just remember another thing I’d like to ask about: Can the original 7 inch raspberry pi touch display from 2015 be used? I’ve tried selecting some of the standard screens, with no luck so far.

1 Like

I have this working.
Configure it in the web-ui
Hardware=>Display=>Advanced View
Select “Generic Display”
In “Config” place the following


Leave Height and Width blank
Set framebuffer to:



yes, as @smiths73v3 says it’s just a generic display and it needs rotating…


Generic HDMI display to be accurate, right? It boots up and then just flashes with the suggested settings on generic hdmi display. (It does that regardless what display I choose). By the way the screen works when using other operating systems.

This is my amp2 machine. It’s using a 7" Raspberry Pi touchscreen . . .

The audio card settings need to be right as well as otherwise you will get resets as Jack starts up and doesn’t find the cards it expects . . .

THis again is the audio bits and pieces for amp2 . . . .IT’s actually got a hifiberry amp2 card in it so it can be forgiving but it needs to be right…

IF you coninue to have trouble log onto the zynth with Putty (if you can see the webconf then sometihng is working and you should be able to get the IP address of the machine)

then stop zynthian running …

systemctl stop zynthian

cd into the /zynthian/zynthian-ui/ directory

and try to start the gui softwre from the command line ( this way you get to see error messages )

post the results here and we will see what we can do…

1 Like

Thank you for the tip! I changed the sound card to dummy, and now the screen works properly! Now I just need to get the sound card to work. It’s an apogee duet. For some reason it worked with a regular monitor and the rapsberry pi 3b connected to it. So the error might have been caused by switching to the rpi 4 or by adding the 7 inch screen.

Sometimes usb devices seem to get different device id numbers for non-obvious reasons.


I had a behringer uca 202 laying around, that one was plug and play with the uca 222 settings. I think I’m going to thinker a little bit more and see if I can get the apogee to work again. It’s a much higher quality device. It turns up when I do lsusb. Any pointers to how to get it to work would be appreciated.

Maybe a power issue. Possibly the apogee tries to draw more power from the usb. Are you using an official rpi psu or some mobile phone charger?


sorry I assumed you has a sound card of some sort.

I have a UCA-222 ( or is it a 202?) I know I’ve had it working but I’ve generally found USB to be crashy. it works but the latency is horrible. and running via a hub didn’t help too much either. Since you need a mouse quite what the bus is set up for on th USB side can be a little bit confused. people mutter words like udev and other peculiar deep and dark things, so definative stateents about USB would be useful.

lsusb will list the connected devices so that will be useful info, so if you can run that on a command line prompt on the zynth that will help.
I will see if I can fire it up on zynthian.ceed.local as that is running as a dummy at the moment. I’m pretty sure last time I tried it, it didn’t work but we can see if we get something conscious.

We normally ask for a phot of it all at this stage because…
1/ it helps us see what is going on
2/ It wins us a bit of time to try things out…

But a picture might be useful.


Yeah, I noticed the 7" Pi display is quite power hungry. I had all sorts of issues until I got to the bottom of that. I had to power directly into the 40pin, and/or run power to the display separately.