New Aruk Stretch SD-image "Release Candidate": RC2

Hi @zynthianers!

I’m proud of announcing the second release candidate of the new SD image, Aruk, based in the ZynthianOS building system contributed by @guysoft:

I’ve tested and almost everything seems to work, but i’m pretty sure you will find the errors i haven’t found.

After thinking a while about giving some guidance on the testing procedure, but finally i realized that perhaps is better to leave everyone to use the software according to his own use-case.

So this is the very short testing guide :wink:

  • Download and burn the SD image

  • Plug the SD-card and boot your zynthian. It should boot twice, so wait until the UI is shown for 20 seconds or more.

  • Update the software for getting the latest fixes.

  • Test everything and take note of every error you find and the way to reproduce it. If we can’t reproduce the error is very very difficult to fix it!!

  • Post your report in this thread or in our Issue Tracking System, taking care of not repeating, please:

  • Sign in to GitHub · GitHub

  • Zynthian Tracker · GitHub

Some features you could test:


  • Check that every engine in the list is working
  • Layers: Create, remove, etc.
  • Layer Options: Add/sort/remove effects, clone, transpose, change MIDI-channel, etc.
  • MIDI-learning: ZS3 subsnapshots (Program Change Learning)
  • MIDI-learning: Controller Learning
  • Snapshots: Load, save, etc. (MIDI-learning should be saved and restored too!!)
  • Audio/MIDI recording & play
  • Admin Menu Options: Single Channel Mode, ZS3 feature, etc.
  • etc.

Webconf Tool

  • WIFI network configuration: hotspot, add/remove networks, etc.
  • Pianoteq License Activation
  • Jalv Plugins
  • MIDI options: profiles, special features, …
  • etc.

Thanks for helping to improve Zynthian!!


Hi @ll,

I have a strange problem with DIN-MIDI-IN:
It works with Gorgona, but not with Aruk(-RC1/-RC2). Here are some Videos explaining the problem:


Aruk RC-2

There are massive drops of MIDI-events. The strange thing is that other users seem not to have this problem and that this is IMHO a software problem (because Gorgona works).

Does anyone have any idea how I can keep looking for the cause?

Regards, Holger

@C0d3man raise an issue here so that we can track it as an issue and it doesn’t get lost / overcloud this discussion topic. I am worried about the use of ttyMIDI which has many limitations and issues. It wasn’t designed as a proper MIDI interface. It is supposed to provide links between ttyMIDI instances and just about gets away with proper MIDI devices, depending on the device MIDI implementation. It has been on my todo list to either contribute to ttyMIDI to improve this or suggest an alternative MIDI library for zynthian. This may be the cause of the issue you are seeing but I am not aware that ttyMIDI has changed between an updated version of Gorgona and Aruk RC-2. I have reported #11 which may also be related. MIDI was not working for me until I did some updates and reboots to RC-2.

Remember to add to the github bug report details of what does and doesn’t work, e.g. whether some engines behave differently and how direct MIDI input behaviour compares with USB input and MIDI Recorder playback. Also describe the hardware interface you are using. I found that a perfectly good MIDI input design failed when connected to ttyAMA0 but the unorthodox zynthian input circuit worked well.

[Edit] There was a change to upstream mod-ttymidi 16 days ago which may be related to the issue you are seeing. Defo open a github ticket then let’s see if reverting to the previous version fixes it for you. This may also give clues as to how to reproduce more reliably.

Happy to see that finally the new build system is helping us get better versions of Zynthian in a shorter time.

BTW, what is the meaning of the name Aruk?

Since this is what is driving me mad at the moment then I thought it was important to share it … :smiley:

It’s JV Fluid Bass on MIDI channel 3

It’s an arpeggio from Motor61 MIDI out Yes, Wyleu has a working MIDI in port on zynthian-amp2.local !! Again.

I acknowledge the wisdom of Jofe once again. :smiley:
It WAS hardware.
The MIDI IN ( ribbon pin 10) and Out (ribbon pin 8) are transported over the ribbon between All-In-One and the Pi ( at minimum ). The pressures placed on the self made ( pliers … Always unsatisfactory… . :face_with_raised_eyebrow:) opened the connector enough to break the connection. I’ve remade the lead several time but it’s never been satisfactory.

So it works! , or I will declare it does after this stops playing… . . .

in … ohhhh I don’t know 10hr’s … ? ? ? Cos it goes … .

And the volume control settings, see discussions previously . . . . is set really low and although it’s properly presented on Top Left Encoder . . . .as can be seen in the recording that goes . . .

It’s really quiet, so that is something we really need to address . . .
Perhaps each class of engine is allocated a champion who can pronounce on this… IT’s the Sine wave issue in reality. . . . I’m probably fluidsynth till I get killed or someone better comes along . . . .
So I Added a FluidSynth Yamaha piano . . .

Incidentally as I went to Recorder to collect this sample of

The top left encoder didn’t control volume level, which ‘feels’ like one should be able to do. so one can listen to …


1 Like

Can’t say I’ve seen any problems. It’s been works or it doesn’t for me…That’s across Two All-IN-One boards. …

It’s a swine of an area to debug . . .hardware/software . . .

Can you see LED’s …?

I have no LEDs in my Zynthian :disappointed_relieved:

I am pretty sure it’s software because Gorgona works. I will checkout an older version of ttymidi and try again. Perhaps I cann find some answers inside the diff.

Regards, Holger

Ok, I found my problem located inside mod-ttymidi. If I checkout a version before the commit “Rewrote the serial to MIDI parsing. Now single byte system messages are handled.” (ed7a2c6d4028c307cf0cee653aacd6b99a10265a) it works so I am pretty sure that this rewrote does not work for all MIDI devices (especially not for my Kawai-MP5).

Here is what I have done to get it working:

cd /home/pi/zynthian-sw/mod-ttymidi
git checkout 028ce4e537c7c1a6c237f90c3747cf1794d2d843
make clean && make install

So: where to open an issue: Zynthian? mod-ttymidi?

Regards, Holger


sounds like mod-ttymidi might be the best place.

How they test this stuff might be of interest.

It should also be added to zynthian issue tracker. We may need to hold zynthian’s copy of mod-ttymidi at the earlier version until this is resolved. We don’t want to break things for people.

Aran + Anuk, my 2 little daughters :hugs:


Totally agree with that, although i would like to understand the details. I mean:

  • What devices are effected?
  • What kind of messages are involved?
  • Could the problem be solved by disabling system messages in the controller device?
  • etc.


Hi @C0d3man!

I open an issue in zynthian’s tracker system:

Please, you open the issue in the mod-ttymidi repo :wink:

Until it’s solved, we will use the last working version prior to the rewrote.

Thanks for opening the issue.

Issue for mod-ttymidi: :heavy_check_mark:

Regards, Holger

Today’s build should include the “frozen” mod-ttymidi …

1 Like

@jofemodo it may be useful to know which changes to the image require us to download a new image and which ones can be implemented with a normal update. It is quite irksome to download the image, unzip the image, flash the image, etc. (This always takes me about a day because I inevitably forget to clear space on the laptop or provide root access to the sdCard, etc…).

All changes can be implemented on “updates”, but it requires more time to deploy, so currently, until the final release is out, only “zynthian code” changes are available via updates, while “software package” changes or “configuration” changes needs downloading a new image.

As i tell you, once the final release is out, all changes will be implemented via update using the “recipe-update” mechanism.



Have just tested this image on my alternative Zynthian build. I’m using a Hifiberry Digi DAC+ and using optical output.

I have to add a -P flag onto the jackd options to get Zythian to start.

 -P 70 -t 2000 -s -d alsa -P -d hw:0 -r 44100 -p 256 -n 2 -X raw

Now the software loads without error, but the audio output is completely distorted. The audio meter shows it as normal. I have to turn an instrument volume down to 1% to hear it without distortion.

This wasn’t a problem on the previous OS. I’ll google and experiment today and If I find a solution let you know.

If you want me to create an issue for this please let me know where.

Now you have -P twice.