New Zynthian build from kit -- No sound, wifi doesn't work

Testing with a new Rasbian lite install and configuring per the HiFiBerry page, I can confirm the DAC isn’t working. I’ll see if I bridged anything accidentally, but I’ll likely just have to get a new one…

WiFi worked without a hitch from the official image, by the way. Perhaps it’s time to re-base the Zynthian image to make sure that RasPi 3B+'s work out of the box?

We are working in a stretch-based image. See this:

The plot thickens… after swapping to a RasPi 3 (non plus), the HiFiBerry worked, using the same Raspbian install that failed on the 3B+. So… then I tried it on the 3B+ and it works now. I haven’t the slightest idea what just happened.

I’m reinstalling the Zynthian image now and maybe I’ll have good news?

For all this technology there really are problems that can only really be cured by sacrificing virgins on full moon nights…


Alright, so now the HiFiBerry works. So I need a workaround for the wifi and that’s it for this thread… but now I’m trying to get my MIDI In port to work. USB MIDI works fine, and the activity LED of the MIDI IN lights up when it’s receiving messages, but it doesn’t appear to be forwarding anything to the engines… any clues here?

the webconf integration is still under construction

Hi @gatesphere!

I’m running several zynthians (built with official kits) with RBPi3 B+ & HifiBerry DAC+ without problems. It runs out the box. Just burn the SD image and plug. Zero problems with sound.

I’ve thinking that perhaps it’s a problem with the power source, Is it a good one with enough power out?
A decent 2 Amp power source is very recommended,


Regarding the WIFI problems, i just uploaded an update that should solve the problems, i hope.
Could you try to update?

Kind Regards,


For the power supply, I’ve been using the official 2.5 amp supply from the Ras Pi foundation the whole time, so I don’t think that was the problem. It may have been a grounding issue — metal case, metal desk. I’m not sure, but it’s working now.

As for update — is it a new image, or do I just have to do the software update process through the admin menu?

Update from the admin menu. New SD images are not so frequent … by now :wink:

Well, that didn’t make the WiFi work, and worse it seems to have broken the entire midi system aside from USB MIDI… even the Test MIDI function no longer works. Is there any way I can help you debug before I re-image?

I don’t mean to sound rude, but shouldn’t these changes be tested in dev before committing to production and risking making things worse without enough testing?

By the way, I also have a RB 3 B+ and WiFi is not available.


Sorry! We are trying to improve the development cycle to avoid this kind of errors.

The new ZynthianOS building system, that we are testing right now, will release images every day and will be easy to create development and production images, among others:

Anyway, tomorrow i will try to fix these problems :wink:


OK! I’ve found the problem. The wifi firmware was not updating correctly.
It’s fixed now and a software update from the admin menu or command line should be enough.
If still not working, try burning a fresh SD with the last Gorgona Omega image and then update software.

Kind Regards,

1 Like

Wifi works now.
I first updated from the menu but it didn’t work. Updating from the command line worked.

I fixed some problems with the update system and now it should work from menu and cli.


And webconf hopefully.

I just tried and it works perfectly too :wink:

2 posts were split to a new topic: RBPi3 Wifi 5GHz support