New Zynthian build from kit -- No sound, wifi doesn't work


#1

Hi all,

I recently built an all-in-one Zynthian kit from the shop, with the Raspi 3B+ model. I can’t get any sound out of the HiFi Berry DAC+ card, and I can’t make the thing use the internal Wifi. I’m a Linux admin by day, so this is a bit frustrating :slight_smile:

What I’ve done to debug the sound part:

  • Verified the HiFiBerry is visible from aplay -l
  • Stopped zynthian and jackd services
  • Tried to get aplay to play the test file (no error, just no sound – the green LED on the HiFiBerry does light up when a file is playing – just no output over either RCA or jacks)

What I’ve done to debug the wifi part:

  • iwlist wlan0 scan (“device doesn’t support scanning”)
  • ifconfig wlan0 up (“no such device”)

The webconf tool works when hardwired into my network, but that’s not ideal. And it’s all kind of pointless if I can’t get this thing to make any sound anyway!


New Zynthian build from kit - MIDI IN port not working
#2

It feels like some sort of firmware incompatibility with the Raspi 3B+, given that the wifi interface isn’t available…


#3

I find it’s sensible to keep a ‘normal’ Raspbian build around on a card to test in a completely none zynth environment, just for sanity’s sake.
That will at least tell you if the hardware is all ok.


#4

Hi @gatesphere!

  1. What SD image are you using? Can you specify the full filename?

  2. Have you updated the software after burning the SD?

  3. Are you using the RCA or the Jack connectors? Have you tried disconnecting the on-board 3-pin audio connector?

  4. Have you tried to adjust the output levels with “alsamixer”? Normally it’s not needed but it could help …

  5. etc

And i could follow … but i’m pretty sure you already did most of that …

The real question here is that if the soundcard is correctly configured and everything is working OK without errors (check the system log with journalctl), it seems like the DAC+ audio output being broken. Perhaps you overheat the card when soldering or you shortcutted something…

Regarding the WIFI problem, a software update should solve the problem. If not, try reading this post:

Regards,


#5
  1. The official one for V2 Kits for RasPi 3: zynthian_gorgona_omega_rbpi3_kitv2-2018-04-03.img. Checked the SHA1 sum against the one on the wiki and it matched.

  2. Yup, no dice.

  3. Tried both, neither works. Haven’t tried disconnecting the 3-pin connector yet, I’ll give that a shot.

  4. Haven’t tried anything with alsamixer yet, completely forgot that existed…

I’ll dig into journalctl and see what I can find out.

A software update hasn’t fixed the wifi issue, though, so I might have to dig into that post.


#6

Following the wifi post lets me get wifi working manually with:

wpa_supplicant -iwlan0 -c /etc/wpa_supplicant/wpa_supplicant.conf

But the ‘Start WiFi’ option on the gui itself does nothing. Well, it starts up wpa_supplicant in the background, but that doesn’t appear to actually try to do anything useful.

Disconnected the jack-plug, no dice. Everything was cranked in alsamixer, no dice. No errors in journalctl. I’m going to re-burn a stock raspbian image on the card and see if I can get it the hifiberry working that way.


#7

I will try to solve this issue in the next update.

Thanks!


#8

Testing with a new Rasbian lite install and configuring per the HiFiBerry page, I can confirm the DAC isn’t working. I’ll see if I bridged anything accidentally, but I’ll likely just have to get a new one…


#9

WiFi worked without a hitch from the official image, by the way. Perhaps it’s time to re-base the Zynthian image to make sure that RasPi 3B+'s work out of the box?


#10

We are working in a stretch-based image. See this:


#11

The plot thickens… after swapping to a RasPi 3 (non plus), the HiFiBerry worked, using the same Raspbian install that failed on the 3B+. So… then I tried it on the 3B+ and it works now. I haven’t the slightest idea what just happened.

I’m reinstalling the Zynthian image now and maybe I’ll have good news?


#12

For all this technology there really are problems that can only really be cured by sacrificing virgins on full moon nights…


#13

Alright, so now the HiFiBerry works. So I need a workaround for the wifi and that’s it for this thread… but now I’m trying to get my MIDI In port to work. USB MIDI works fine, and the activity LED of the MIDI IN lights up when it’s receiving messages, but it doesn’t appear to be forwarding anything to the engines… any clues here?


#14

the webconf integration is still under construction


#15

Hi @gatesphere!

I’m running several zynthians (built with official kits) with RBPi3 B+ & HifiBerry DAC+ without problems. It runs out the box. Just burn the SD image and plug. Zero problems with sound.

I’ve thinking that perhaps it’s a problem with the power source, Is it a good one with enough power out?
A decent 2 Amp power source is very recommended,

Rregards,


#16

Regarding the WIFI problems, i just uploaded an update that should solve the problems, i hope.
Could you try to update?

Kind Regards,


#17

Hi,

For the power supply, I’ve been using the official 2.5 amp supply from the Ras Pi foundation the whole time, so I don’t think that was the problem. It may have been a grounding issue — metal case, metal desk. I’m not sure, but it’s working now.

As for update — is it a new image, or do I just have to do the software update process through the admin menu?


#18

Update from the admin menu. New SD images are not so frequent … by now :wink:


#19

Well, that didn’t make the WiFi work, and worse it seems to have broken the entire midi system aside from USB MIDI… even the Test MIDI function no longer works. Is there any way I can help you debug before I re-image?


#20

I don’t mean to sound rude, but shouldn’t these changes be tested in dev before committing to production and risking making things worse without enough testing?

By the way, I also have a RB 3 B+ and WiFi is not available.

Thanks
Christian