No sounds from the 1/4" outputs (soundcard)

Hello all,

I’ve just finished assembling my zynthian V4.4 (Got last week).
All seems working correctly, could connect trough ethernet and Wifi.
By connecting a keyboard to midi in, the led (Midi in) is blinking when the keyboard keys are pressed.
But I can’t get any sound at the 1/4" jack outputs (soundcard).
By enabling the RBPI headphone, I can hear the sound test from the headphone output but never from the soundcard output.
I don’t get any sound from the instruments (no sound at all, not from headphone out, not from the soundcard)
I’ve also done the software updates (triggered from the Web UI).
What could be wrong ?

Thanks a lot !

You might make sure the ribbon cable is installed correctly. i.e the red wire is on the side with pin 1 on both ends.

  • Please, could you send some photos from your zynthian internals?
  • Could you check if the soundcard LED is on?
  • What SD image are you using?
  • Could you send a screenshot from the webconf dashboard?


OK, thanks for your help.
I don’t have the unit with me. I will do this this evening !

Thanks !


What is really strange is that you get the test sound on the RBPi headphones but not instrument output. You should try again.

Perhaps burning a fresh image without updating could help.


Hello again,
I’ve tested again without changing anything. The audio test could be heard from the headphone output but nothing from the main output. On new information is that I could also hear the piano (headphone socket) with the midi test.
I’ve reburned with a fresh image (without doing any update), but now I have no sound at all :frowning:
For the image I’ve downloaded the file from the Wiki.
Dashboard copy:

Picture from the inside:

Thanks !!

Is there a main volume which could be set to 0 ?

I think I’ve found the problem:
A faulty Zynaptik module. Could this be possible ?
I explain: the really first time I booted the Zynthian, I had nothing (I’ve double checked all the connection before applying power).
At that time I thought it was the SD fault and checked this. I’ve also replugged all the connectors.
But here is the point, the second time I’ve connected only the first array of pins from the Zynaptik module. After these operation the PI booted, but with the problems I’ve described (no audio).
This evening I’ve seen that the connector was not correctly in place, put it in place and then again, not boot from the PI (as the really first time). By disconnecting the Zynaptik module the PI is booting. So it seems the Zynaptik module generates troubles…

Is the main audio working OK when the zynaptik is unplugged? Of course, if the zynaptik is broken, i would send you a replacement ASAP.

Also, if you can hear the audio test with the headphones, you should hear the instruments too. Please, check this again.


Hi again, sorry !!
I think it’s getting clearer…
I’ve completely unplugged the zynaptik and (after software update) the audio and midi tests are working through the headphone output.
As I tried to trigger synth sounds using the midi din sockets, the led is still flickering (from the midi loop current I guess) but the data are not arriving at destination.
As a side effect also, the encoders are now also working correctly. Previously I could navigate but had some random jumps in the menu.
So now I can reasonably presume that the synaptik module is disworking ?
Thanks !


Hi @fschenckel !

The MIDI functionality is implemented by the Zynaptik, so it’s not possible to receive/send any MIDI thru the MIDI DIN-5 sockets. Yes, you will see the light provoked by the current loop, but nothing more.

Now the more important. Is the main audio output/input working?


Yes, the 1/4" output is working properly! Sound + Midi test !


I’ve just tried midi through USB, it is also working :slight_smile:


So then, it seems we have a broken zynaptik …

Please, try it again and if it’s not working yet, i will send you a replacement ASAP.
When you receive the replacement, please, send me the broken zynaptik by cheap “standard postal service”, so i can figure where the problem is.


OK thanks, I will check this this evening and will come back with the status.

Hi @jofemodo,

I tried again to connect the Zynaptik board, but nothing to do, the board is not starting at all. No led is lightning, seems to create a short circuit.
Sure I can send you the board back. How do you want to proceed with the details ? Per private mail ? Or we continue here ?
Thanks !

does running 12cdetect -y 1 on the zynthian reveal ports occupied?

All is working correctly when the Zynaptik board is disconnected ! With the Zynaptik board connected the rapsberry doesn’t start at all !!


Is the MCP 23017 in a socket?

No, it’s directly soldered.
I’ve taken a picture of the chip, it seems that some pins (near C4) are soldered together. Is that wanted ?