Notes hanging / Zynthian misses note off? [SOLVED]


#1

yea, I think the title says it. It happens quite often that different notes are hanging. Could this be a software problem? I have this for some weeks now


#2

i had those as well. But I blamed my Behringer FCA1616 / Tracktion combo and took a different Midi interface for MIDI IN.


#3

I have a dave smith mopho keyboard that I’m using as midi keyboard for the Zynthian. Should actually be good quality and I didnt have this issue until some weeks ago…
but I will check with something else


#4

I get hanging notes when I connect my fullspeed usb keyboard to Zynthian’s usb interface, that is configured to work at highspeed by default.
Some fullspeed usb packets get lost, this is caused by an issue with usb interface on RPi3.

If you’re using only fullspeed usb devices, adding the next parameter in boot/cmdline.txt could solve the problem:

dwc_otg.speed=1

This forces the usb interface to work at fullspeed only.
The disadvantage is that you loose the support of highspeed devices.


#5

thanks for the hint! I tried it but unfortunately it didn’t solve the problem. I will try it with another keyboard later


#6

I will test deeply to see if i can reproduce/solve the problem with my keyboards. Most of them are cheap and low-quality ones …

Regards!


#7

thanks jofemodo!

I also tested further. So, the problem did not appear with a nord electro, but then it appeared with a micro korg too! So I think it cant just be the problem of my mopho. Cable can also not be the problem because I tried it both with midi cable an also with usb cable


#8

could it be that this started with an update in september or early october? Because I remember when I had several rehearsals in september this never happened

another thing I found out is that it only occures when I press notes longer than about 2 seconds!


#9

Is this behaviour consistent? Does it happends always or there is some pattern? Does it happends randomly, but with the 2 seconds constriction?

Thanks!


#10

Hi there,

I also have this problem of endless notes. I use a micro korg XL connected by USB.
It happens very often.
The issue with the midi handling seems to be bigger when using Linux Sampler (some notes are delayed and some “gost” notes are played)


#11

sorry for the late reply…
as far as I can say it is consistent, happnened for me in every engine, noticable with all sounds that are able to ring continuously. Maybe its also 1 second or 1,5… but I never made it happen with short staccato notes.


#12

Could you try with the last SD image “Gorgona-Next”?

Regards!


#13

will try and install it on the weekend, after I had the first concert with zynthian! (only marimba and celesta sounds there, so no problem with the haning notes)


#14

updating from within the zynthian should update to gorgona next am I right? (went pretty quick thou…)
Anyway after doing this the problem still persists :frowning:


#15

Hi all.

here

an example of the same problem that happen to me:

CLAVINOVA CVP 407 tested with different usb interface but… the zynthian hang note randomly when playng.

i mean: when playing WITH or WITHOUT sustain some note hangs… until you play the same note again… then the note stop playng (or even if the polyphony stop the note! :wink: )

zynthian is working with the latest gorgona image downloaded yesterday.

NOTE on my microkey 61 korg no problem at all :slight_smile:


#16

Now that you say that, I remember that when I built your Zynthinan I first tried MIDI interface using the Yamaha PSR1500 and had the same random problem. But never had a single note hanging using the Novation MiniNova as MIDI keyboard.

And no problem with a couple of USB keyboards I tested: an M.Audio Keystation Mini 32 and an Alesis Q49.

Your Zynthiand loves minikeys… or hates Yamaha… :smiley:


#17

whait whait wait…My Zynth CAN’T hate Yamaha, because it know that i love it! :joy:

Btw:it’s very strange because with “zynthian_gorgona_edge_rbpi3_pitft-2017-09-18.img” i never had any issue… right now im’ playng my zynth like a charm!
so maybe the problem is with PSR’s brand? too cheap for zynth?:joy::joy::joy::joy:


#18

something really bad has happened with the software

now all engines and notes are all over the place,hanging , ghost notes etc


#19

I can’t reproduce this behaviour, so it’s difficult to figure out what is happening. I’m not completely sure that it’s a zynthian-related problem, as most of keyboards works perfectly and only a few ones have this problem.

But … I can imagine an scenario where this could happend. The new MIDI filter uses a fixed-size event buffer (1024 events), that could be exhausted if there were more than 1024 events in a given frame (normally a frame is about 5-10 ms). If the keyboard where sending a lot of MIDI events it could happend …

Could you try to increase this buffer size in the zyncoder library? Look at “/zynthian/zyncoder/zyncoder.c”, line 412:

uint8_t jack_midi_data[3*1024];

and try with something like:

uint8_t jack_midi_data[3*8192];

recompile the zyncoder:

cd /zynthian/zyncoder/build
make

and stop zynthian service and execute zynthian from command line:

systemctl stop zynthian
/zynthian/zynthian-sys/sbin/zynthian.sh

If the problem persist, look for this message in the output log:

Zyncoder: Error processing jack midi output events: TOO MANY EVENTS

Regards,


#20

i’ll try asap: for sure i can test the issue properly… :wink: hope that we found the solution for this problem.

But, as you have say, it happen only with some keyboards…