Notes hanging / Zynthian misses note off? [SOLVED]


#41

aye captain! Sorry you need to have so much patience with me…
but weird that the search of cyberduck, my ftp client, did not find it there

p.mid (1.3 KB)


#42

Hi… here are my two midi recordings… happened quite quickly:
note hang.mid (117 Bytes)
note hanging from zyncoder.mid (928 Bytes)

Recorded from mid and from zyncoder output too…
i took a look at both .mid inside a sequencer and note it’s like being hold physically.

From serial midi in my case no hanging notes…


#43

Please, @ivanmonterosso & @Hampelschwein, could you tell me what MIDI input you are using? USB or standard MIDI-IN?

If notes are being “hold physically”, then there is nothing i can do. It’s a problem with the keyboard, that doesn’t send the note-off.

If you are using USB, have you tried the @Schpion recipe:

Regards,


#44

i tried both usb and midi. In the case of my uploaded p.midi file it was the midi cable way. they are surely not held physically as it only happens for my mopho keyboard when I use the zynthian as the sound source, not with the mophos internal sounds or my macbook. Also tried Schpions trick, which also didnt change it.


#45

Have you tried with your MacBook recently? Can you confirm that it only happens with Zynthian?
If so, it’s really strange …

Regards,


#46

yes i tried it just now with the macbook, its not happening. also with the internal mopho sound which i use very often


#47

Then we have a true X-file. Let me check your MID files carefully …

Regards,


#48

yes, i tried that trick for something else (perhaps issues with usb audio interface) but got other things worse…then i returned “normal”.
Anyway this is related to usb midi. Serial midi goes apparently fine.


#49

mine happens on usb from my korg monologue and usb to midi adaptor to my korg monologue

and I noticed it quite a lot on the key of D


#50

USB midi also for me… :wink:


#51

Hi guys,

I think I found a hack !
I use a microkorg XL.
When I put my keyboard midi clock to “ext USB” (clock was set to ‘internal’, initially) it seems to work fine, no more endless notes and ghost notes :slight_smile:


#52

I’m running a korg monologue with no option of external midi clock… @jofemodo

is there possibleity to have a option in the zynthian software to turn off midi clock or have some change


#53

Really strange! Currently Zynthian doesn’t know nothing about clocks, but clock message could be the cause of missing the note-off messages. Perhaps some message buffer is overrun …

@christianforshaw, could you disable the internal clock for the monologue (if there is internal clock) ?

Anyway, if the problem is “clock messages”, i think i could solve it:

1.) First “quick and dirty” solution: add “clock messages” to MIDI router so we can “IGNORE” it.
2.) Second, find the exact place where the problem is located and solve it. Knowing the origin is a lot easier to find the problem :wink:

Thanks!


#54

I don’t know if this is important for this topic, but I tried to sync Zynthian to the MIDI clock of my Roland-A880Pro master keyboard. So I enabled the MIDI clock and after that I had massive dropouts.

Can you double check if MIDI clock is disabled in your MIDI"-network"?

Regards, Holger


#55

@jofemodo the monologue can not have its clock disabled

There is 3 options

Midi
Usb
Internal

I’ve tried all 3


#56

Then try USB or MIDI option, not internal.

Regards,


#57

I’ve tried all 3 options and they have the same results


#58

This will be the same as a lot of synths… Proberly a cheapo midi keyboard that only does midi will work fine


#59

also here… hanging note still remain on different setups of MIDI clock.


#60

Just to throw gasoline on the fire :slight_smile: , when I did that test both the PSR (that had hung notes) and MiniNova (that worked without problems) had MIDI clock output stream enabled.
Both of them tested using the MIDI interface, with the Gorgona Edge image.