Notes hanging / Zynthian misses note off? [SOLVED]


Wonderful. This issue is getting more and more funny every minute … please keep posting strange behaviours and perhaps i could take all the info to my “Chaman” and make some kind of ritual, burning 2 or 3 expensive “MIDI-clock-generating” keyboards with “sacred fire” :joy::joy::joy:


Ahem, I have a big fireplace in my house. Just send those keyboard to me, I’m volountering to do the rituals.
For the best ritual result, please send me an Arturia MatrixBrute, a Virus Ti Keyboard, and an Clavia Nord Lead A/1
:smiley: :joy:


in my mopho I have the Clock options internal, Midi In, Midi Out, Midi In/Out. Tried all 3, nothing changed


I tried now to play my Clavinova whearing the sacred autoharp’s gloves of Jean Michel Jarre and… success! I look like an idiot!:sunglasses:

but the notes still hanging! LOL :joy:


Seems I’ve found a trick that kind of fixes it on my monologue


after a small test I found its not doing ghosts notes or random notes as much, but still doing it…


Hi, any news about this issue? I have got three keyboards and only one - cme u-key - has this behaviour on both Usb and serial connections. This issue begun after one of the updates in November. I’v got my zynthian for a year now and previously everything was ok. Trying to change various settings on keyboard but unfortunately nothing get better.
Also trying to use fresh gorgona image (2016) without updating and it work without this issue.


No improvements have been done in this issue. But i will do in the next weeks.

OK. This is a good starting point. It seems that the issue is related with the MIDI filter feature.



I have the same problem with old 2 Generalmusic keyboard but not with my Fatar Studio 88 (this keyboard transmit only pure message of note, velocity and sustain control.
I Think… On all generalmusic keyboard is active the “midi active sense” message…
can this be the problem? as soon as I go to the studio I will try to filter this type of message through a motu mtp av…


Nice, I have that one as well. Sometimes I the red LEDs are hanging though and I thought if one could change the internals with a zynthian one :slight_smile: But my problem started with different voltages. 5V and 9V

I can reproduce something as well.
When I put an additional USB Midi cable to the v2 zynthian, I have a looping f1. No hanging notes, but always the same in a loop while I have other keys pressed.
I haven’t logged midi messages yet. Do you want them?


@varnish / Fatar Studio 88
Did you have issues with the varnish like me?
It became sticky and a refurbished it completely.


Check the power supply of Studio 88 because if I remember correctly there is a classic integrated 7805 stabilizer that brings the input power to 5v. If so, you could feed everything at 5v. I use a 12v transformer without problems.

My Studio 88’s paint is perfect and immaculate.


I had a GM device, that made the FS88 stall. All LEDs were on. Arbitrarily.
I could solve it by unplugging the volume pedal.
Did you experience that as well?


Hi jofemodo et al.,

Maybe it helps:

I have no issues using FluidSynth and love it.

But on ZynAndSubFX, LinuxSampler, setBfree and MOD-UI I have big issues with dropped notes, missing notes-off, ghost notes - it is really not useable.

I also have a pisound running MOD-UI to compare with which is running with no flaws.


Thanks for the report. I’m working for solving the problem …


Hi @zynthianers!

Good news!

I’ve fixed the zyncoder library. I discovered that some MIDI messages were not processed correctly (active sense, time-code, etc.) by the MIDI router. I also have “filtered” SysEx messages until i can write and test the code to correctly address this messages.

With this fixes, keyboard-specific / fluidsynth problems are solved in my zynthians. Could you test the changes and see if your problems are solved?

You only have to update … or wait for the new “Omega” SD image that should be out in a few hours :wink:


New SD image: Gorgona Omega

I tested it with a slightly different set-up and it seems to work. I will see on Thursday if the original buggy set-up is fixed.


Nice … i will be waiting your confirmation :wink:


It works :slight_smile:


Nice!! I think the problem is solved. There is a problem yet, when receiving big sysex messages, but it’s not so common and i will solve it in the next iteration.