Snapshot bug

Hi, @jofemodo, with reference to this post, I thought it would be better to branch out a new thread. (Actually wanted to post a new issue in github but I couldn’t figure out how to attach files there).

So the problem was as follows:
Pushing short-back twice led to empty screen and UI freeze (just blue / black background and zynthian logo). Access via ssh was still possible.
This situation appeared (only (?)) when the zynthian was booting directly to the LAYERS screen if I remember correctly. Unfortunately, I don’t remember how I managed to achieve this. Can you assist here? What do I need to do that immediately after reboot or power on zynthian goes to LAYERS screen directly? Whenever I reboot now, I always am greeted by the CONTROL screen of the synth that is in the layer or by the MAIN screen if there was no layer. From here, I can’t reproduce the bug.

BUT, I still have a buggy snapshot: last_state.zss (15.4 KB). You can try. Start with plain configuration, i.e. delete all layers, and delete all snapshots from webconf. Then load attached snapshot. It should bring up the LAYERS screen.
(I generally have both options “Preset Preload” and “Restore last state on startup” enabled.)

Now, from here on, there are three distinct scenarios that I was trying out. 1 and 2 lead to UI freeze, 3 does not.

  1. Pressing back-short once brings up MAIN screen, pressing once again, brings up empty screen as shown in my original post. --> UI freezes,

  2. While in LAYERS screen, navigate to REMOVE ALL and confirm by short select. short-back twice --> freeze,

  3. Press short-select to get into CONTROL screen of the instrument. After that, any user action is possible without causing any error. Including short-back as often as you like. --> Everything works normal.

There seem to be a couple of variations to this depending on how deep you navigate into screens and go back and possibly delete layers and / or delete / reload snapshots in between. Sometimes UI freezes, sometimes not. Really confusing, and so far, there is no apparent logic to them.

Where do I see what SD image I actually have?
I can provide output from command line:
root@zynthian:~# uname -a
Linux zynthian 4.19.66-v7l+ #1253 SMP Thu Aug 15 12:02:08 BST 2019 armv7l GNU/Linux
from webconf:
zyncoder: master (11e32fa)
zynthian-ui: master (3319a37)
zynthian-sys: master (a305ab9)
zynthian-data: master (9cccef5)
zynthian-webconf: master (ab294aa)

(BTW, a system info screen on the zynthian would be really cool, where such information is gathered, like time of last update, sd image version etc. :slight_smile: )

regards.

1 Like

I think it’s solved now! Update and test, please :wink:

hmm, still the same as before. I tried loading that mentioned snapshot and still, short-back twice brings me to that nearly empty screen and UI freezes. Am rebooting from webconf.
current system:
zyncoder: master (11e32fa)
zynthian-ui: master (f0ed0a7)
zynthian-sys: master (ccad6f8)
zynthian-data: master (9cccef5)
zynthian-webconf: master (ab294aa)

Your snapshot is loaded normally.

my user interface freezes on the open layer after repeatedly clicking the “Back” button, the web configuration still works…

009-EpicEnteR.zss (39.4 KB) … other snapshots load normally.


I’m re-save the snapshot and a few reboots solved the problem.

I’m seeing more or less the same thing on this last_state.zss (16.7 KB) snapshot: after a fresh reboot with that loaded, hit back twice (layers -> main -> hang) and the UI hangs up with mostly blank screen. While this snapshot is loaded, “Save snapshot” actually opens “Load snapshot” menu.

If I remove remove all layers and start a new snapshot then neither of those oddieties happen, so maybe this is just a result of said snapshot been created on some buggy, intermediate version.

change one of the parameters, for example, the volume of one channel, then you can save the snapshot …

Yeah I got it to save by removing the layers, and that seems to have cleared the save -> load issue… and apparently the back button hang too, as I’m not able to reproduce either now, whereas it was 100% reproducable before saving that new snapshot.