Testing the next release: Staging-2104

Hi crew!!

I just created the “Staging-2104” branch that will be the next stable as soon as we are sure of not introducing any serious bug. For testing you must change all your repos to “staging-2104” from webconf. Please, test as much a you can and enjoy.

No more features should be added to this branch, only bugfixes, if any :wink:

The list of UI changes:

Most of them are fixes and little improvements.



Fix #371: When adding FXs, show preset selection if available.

Nice !

1 Like

Cool! We need to avoid being tempted to fix other bugs though. Only fixes to fixes (or features) already in this branch

I was thinking just today that we need to do this. I’ve been busy with the day job but will find time next week to look at this. Let’s try to get this done this month, before it’s tag is out of date :wink: but not push out if broken.

Here is your chance to get involved and contribute even if your coding skills are even worse than mine! Test, test, test then test some more and report EVERYTHING you find, however trivial. Add bugs to issue tracker.

Thank you, you wonderful people. :heart: .


As it seems everything works OK, i will merge staging-2104 with stable. You, advanced zynthianers, have the last opportunity of saving stable users from a terrible bug with scaring consequences (remember the banjo SFZ incident !!)

Estimated Merging Date/Time: 2021-04-30 19:00 UTC



I am trying to do some tests but challenged by being away from home with a Zynthian and poor PSU. I will check a few things but might have missed the deadline. (Doing actual work today so only just saw this message.)

The VNC desktop panel looks bad on my development zynthian. This might be the result of work to enhance it which may not be undone by a git update. Check that it is acceptable.

VNC password remains “raspberry”. I guess that fix doesn’t warrent fast forwarding to this release.

I don’t think many of the tickets assigned to the sprint are resolved - probably because they are mostly mine and I have been occupied by other work. They will have to roll over to next release.

I don’t know if I pulled the right version but some of LS sonatina’s samples are silent on stable (logs says cannot load preset). It is probably related to SFZ file though…
I also have the same issue with audio recording which I mentioned earlier on discourse and issues tracker (occurs also in testing).

Staging-2104 is merged on stable. An stable-2104 image is being generated right now.



AFAIK, we have not changed anything related with the LinuxSampler engine.
Could you test if these SFZs work OK on testing?



The same result is on testing branch:

May 01 10:55:14 zynthian startx[2132]: INFO:zynthian_layer.set_preset: Preset Selected: sonatina/Sonatina Symphonic Orchestra/Woodwinds - Bassoons Sustain (2) May 01 10:55:15 zynthian startx[2132]: ERROR:zynthian_engine_linuxsampler.ls_set_preset: sfz (ERR 0)
Same problem with Timpani, Basson Solo, Clarinet Solo, Contrabasson Solo, Tenor Trombone Solo, Cymbals&BoomBam.
Other SFZs from Sonatina’s pack are fine.
Has Linux Sampler got any more verbose error logs while reading preset?

Hi @jofemodo ,
my log from today update - software-update-2021-05-01.log…txt (94.6 KB) . There is one “fatal” mark

With standart sfz file I not found any problem, but I tested only a few sounds.
last_state (4).zss (24.4 KB)

1 Like

The log seems perfectly OK! There are some confusing messages that should be hidden, but nothing to worry about.

BTW, is it everything working OK? :wink:


Just applied the update and there is some odd MIDI routing behaviour on my machine:

  • The setting “Route MIDI to output ports” does not “survive” a reboot. When I reboot it routes for less than a second and then it’s gone. The only way to activate it is to go into the MIDI settings in the Web UI and simply press “save” (nothing else needed, because the option is still checked).
  • MIDI clock is always routed. My assumption is that this should not happen if the option “Enable System Messages (Transport)” is not enabled.

While I had the clock issue before (open bug on github: SYSRT Clock is always routed when "Route MIDI to Output Ports" is enabled · Issue #445 · zynthian/zynthian-issue-tracking · GitHub ), the reboot issue is new.

Could you test on the testing branch?

The updated image for stable-2104 is ready, although i’ve not tested yet. I will test it ASAP, please, do the same if you have a chance:


Once it’s tested, i will change the link that point to “last-stable”.


I just switched the repos to testing and ran software update. Same two problems: Routing to outputs is only activated when “save” is pressed in MIDI settings and then clock is always routed.

@jofemodo Hi ! Since the last update, when I activate the VNC server, in the VNC viewer or novnc, only ZynAddSub and pianoteq are showing, all the LV2 plugins are no longer visible !

You have to re-generate the LV2 cache from the webconf. Simply click “Search for new plugins and presets” from the LV2 tab.


1 Like

Hi @catherder !
I can’t reproduce your problem with enabling/disabling “MIDI Filter Output”. Could you give some details about your setup/context?


The problem is related to the “Route MIDI to output ports” option, not the filter. However I am just downloading the latest 2104 image and will try a clean install this afternoon. I had it before that while updating caused problems, doing a fresh install worked finally. My setup is a “clean” Zynthian with custom hardware (HDMI touchscreen and Tascam US 4x4 four channel audio).