Working with pure data


#1

hello everyone, last week i got my Zynthian soldet everything all workes fine.
but i was not so happy with the software, so i installed raspberian and puredata
and everything works well.
but i have no idea how to get control of the potis in pure data and at all
maybe someone could help
thanks and greez
alfred


#2

Hi @alfred!

Why you didn’t like the software? Could you elaborate a little bit?

Regarding your question, i think the easiest way of integrating the zynthian controllers (“potis”) with pure data would be to create a puredata “zyngine”, integrated with the current software.

https://github.com/zynthian/zynthian-ui/tree/master/zyngine

If not, you could try to use the zyncoder library, or take from the code the parts you want for creating your controller library:

https://github.com/zynthian/zyncoder

Kind Regards,


#3

i am more interested in pure data than in more vst like synths, sampler and fx
and i was searching for some small box like Zynthian to work with patches without a laptop. i also tried out organelle but wanted to see my patches on a display…

i will try to work with that library thanks !


#4

OK! Keep us informed of your advances, please :wink:


#5

so i managed to install the zyncoder library
and i have “alsa sequencer” for my usb faderbox witch works
but i could not find the zyncoder knobs
should they show up in the alsa sequencer ? or how could i get them as midi faders?
please help :slight_smile:


#6

Hi @alfred!

Take a look to the example program “zyncoder_test.c”

But first pull the latest changes. I’ve fixed it for using MIDI-CC 70-73.
Before building, you should define the environment variable:

export ZYNTHIAN_WIRING_LAYOUT=MCP23017_ENCODERS

as it’s v2’s wiring configuration. After that, from the same terminal:

cd zyncoder_dir/build
cmake ..
make

When you run the “zyncoder_test” binary, a jack client called “Zyncoder” will be created (jack daemon should be running!!). You can connect the Zyncoder’s MIDI output to pd and will receive MIDI-CC 70-73, corresponding with the 4 encoders. The problem is that PD doesn’t support jack and zyncoder currently doesn’t support ALSA seq. You will need some kind of bridge, like a2jmidid :wink:

Regards … and good luck!!


#7

hello, when i run zyncoder_test i get the messege:
gpio: Unable to open GPIO direction interface for pin 17: No such file or directory
wiringPiISR: unable to open /sys/class/gpio/gpio17/value: No such file or directory


#8

You need to run the program as root or give permissions for accessing the GPIO to your user.

Regards,


#9

i ve done it as root same messege


#10

Is there a branch already? I am interested in a pure data integration as well.


#11

i think there is no integration yet…


#12

Yes, thats why we need to do it. A lot of ppl are asking for pure data


#13

i m a total linux rookey…


#14

I’ve created a task in the github repo:

I’ve been testing with this patch:

generative_relaxing.zip (6.3 KB)

It’s a generative patch that can be tuned using CC 1,2,3,4 & 7.

Regards,


#15

oh wow great thanks !


#16

I’ve a initial version of the PureData engine. Pull “puredata_zyngine” branch of zynthian-ui repository :wink:
Something like this:

apt-get update
apt-get -y install puredata
apt-get -y install python3-yaml
systemctl enable a2jmidid
systemctl start a2jmidid 
cd /zynthian/zynthian-ui
git fetch
git checkout puredata_zyngine
reboot

I’ve prepared some demo patches that you can try and use as example:

puredata.zip (49.0 KB)

Simply copy to the “/zynthian/zynthian-my-data/presets” folder and unzip :wink:

Enjoy!


#17

my problem is that i could not get wlan on the zynthian.
i also tried to take the same networkconfiguratione than in the raspien but didn work.


#18

Have you read this post?

Regards


#19

didnt work, also tried this


#20

Could you send the output of this 2 commands?

ifconfig
iwconfig

Also, note that if you are using the aluminum case, the internal wifi device will receive a very weak signal and only will work if you are really close to the router. If not, you should use an usb dongle.

Regards,