External MIDI sync & SooperLooper

Hey there, I’m quite new to the zynthian project so apologies if this seems a daft question.

Zynthian stable on rpi4 8gb
Focusrite 2i4 2nd gen for audio and Midi IO
Keystep pro

I’m attempting use the keystep as an external clock source for the zynthian but have had no success so far, does anyone have any pointers on how to configure this?

  • the end goal is to use the SooperLooper with bass/guitar so they can be synced with midi instruments.

  • the KS is attached via DIN to the focusrite (although I’ve also tested via usb). note on/off messages are received so I can play instruments, but the tempo settings screen is unaffected by the KS sequencer

  • I don’t see clock messages in the midi monitor in the web conf, but monitoring elsewhere (ie unplugging from zynthian and into another device) confirms they are being sent. I’m not 100% sure if this is because of a routing issue or just that the monitor doesn’t support them.

Thanks in advance!

(Also, I’d quickly like to express how impressed I am with the project. I’ve been looking for something to do exactly this for a while now and I’m really excited to see what I can do with it)

Hi @clmain!

May I extend a warm welcome to you. You describe an entry to this platform that is similar to many of us. Zynthian does what we were looking for or trying to create for ourselves. I hope you enjoy the device and the lovely community.

To enable external MIDI clock sync you select it in the tempo screen: “Clock Source”. Default is “Internal Send” which uses the internal clock / tempo and sends MIDI clock to external devices. “MIDI” uses an external MIDI clock as it’s timebase which is what you want I think.

1 Like

Hi @riban

Thanks for your quick reply!

Sorry, I should have mentioned in my original post, but I’ve already got it configured to "MIDI"in the tempo screen.

Webconf MIDI monitor had an option to enable system messages which include clock. This is disabled by default.

Welcome @clmain

Zynthian can be looked as a “not as usual instrument/DAW/looping station/…”
Maybe that’s what it is. I do not know, cause the lack of playing with all these gears.

but in fact it’s a really capable and flexible toy.

It works (more or less) with that “non official” setup:

This is a kind of prove of concept (more or less) imho

BTW: do you use it with a touchscreen or headless ? And do you know :

1 Like

I had enabled system messages but couldn’t see clock messages, which was why I was unsure whether the issue was with the controller or with the monitor - I can see them using other devices.

At the moment I’m using vnc but once I’m more familiar with it I’m planning on getting a touchscreen, then building a full enclosure. Once I’ve got looping sorted though I’ll probably start with a foot controller :slightly_smiling_face:

1 Like

From webconf tool ?

is the beatstep the controller ?
Zynthian UI should workout the box on an HDMI display (connect a mouse)

Zynthian’s VNC features can do 2 things:

  • display Zynthian UI
  • display Zynthian engines natural interface
1 Like

I tried midi log in webconfig, becouse I have similar setup (Raspi 4, Behringer UMC 1812 and Arturia BeatStep Pro.

When I selected Arturia BeatStep Pro MIDI 1 and Show all message, on the log was show sysclock.

After switch to ZynMidiRouter Main, the sysclock message was missing. Even though I had set “Clock Source” on MIDI as describe @riban.
The classic question, is it a bug or a feature?

In the Webconf MIDI monitor yes. Update on that front - I can see SYSCLOCK Messages in the “Scarlett 2i4 USB MIDI 1” Section, but not under any of the Zyn options (Router, Master etc). Does that suggest that the messages are getting to the OS but are not being routed into Zynthian itself?

Apologies, “monitor” probably wasn’t very clear. What I meant was whether the Keystep was unable to talk to the Zynthian, or the MIDI Monitor didn’t support SYSCLOCK messages (as noted above I’ve disproved that theory).

I don’t have a spare monitor easily available but I do have a tablet, so I’m doing everything either through that or through a computer (both viewing the WebConf, Zynthian UI or the Engine UI)

Ok, there’s a slight difference here, I have the BeatStep connected directly, you via the sound card. As a result, both of us do not see sysclock in ZynMidiRouter Main and ZynMidiRouter CH#…

thks for clarification

A small update (I’ve been away so not had a chance to play around in the past couple of weeks).

To eliminate the soundcard as a variable I’m now plugging the keystep into the pi directly via USB as well.

As previously identified I see SYS CLOCK messages in the webconf midi log under the “Keystep Pro MIDI 1” section only. However, when enabling "Route MIDI to Output Ports " in the MIDI config in webconf, I also see the SYS CLOCK Messages in “ZynMidiRouter MIDI-OUT” and “ZynMaster MIDI-OUT”. That suggests to me that the messages are being received properly at least, so the problem is likely with how they are getting to Zynthian.

I’ve also observed a bit of odd behaviour in the Tempo Settings of the main UI. If the MIDI Clock on the keystep is running and I toggle the clock source in Zynthian between “MIDI” and any of the other options, the tempo jumps randomly. That could suggest that some of the clock messages are getting through badly, or it could be a bug.