New Engine: Pianoteq

Hi Zynthianiacs,

some very good news for all Piano/E-Piano-Fans:

The company Modartt has developed for some years an excellent piano simulation (yes, it’s really more a simulation than a sampler - massive mathematics inside!). The best thing of all: They released their version 6 binaries not only for PC (amd64, i386) but also for Raspberry Pi (armhf) - and they also released a nice demo version of their software (try before buy)!

:arrow_right: @jofemodo, @mheidt and @C0d3man proudly present: Pianoteq6 engine for Zynthian - this time a commercial software.

After an update of your Zynthian you will see: nothing new :disappointed_relieved:

… but: Give webconf a try and point your browser to http://zynthian.local (or the IP of your Zynthian). You will see a new menu-entry named Software. There you can upload a binary of Pianoteq. You can download the demo-binary from the webpage of Pianoteq and install the downloaded file via zynthian-webconf - Software. After a reboot you should see the new engine!

:warning: Note: The demo version stops playing after 20 minutes - you have to choose a new (or the same) sound again for the next 20 minutes. Also some black keys are disabled!

You can also install a licensed version. For activating the license you currently need the official UI and have to start Pianoteq via ssh -X. We will describe this later inside the Wiki (or in the forum).

We want to ask Modartt for working together with Zynthian. For this we need to know, if you think about buying a license - so please let us know if you will do so.

Regards, Holger

P.S.: My absolute favorite is MKI - Jazzy

P.P.S.: We are using Pianoteq6-Stage. There are other (and more expensive) versions, but they need more CPU power (this is also the reason for activating only 24 polyphone tones and not more). Also the full access to all parameters is currently limited and only fully working when using the included UI (you need to login with ssh -X). This may change if we can work together with Modartt.


When we talk to Modartt it might be good to know, not only if but how much you would pay for a licence.


Prices: Pianoteq6-Stage costs $129

It comes with 2 instrument packs, you can select either Acoustic, Electric or Vibraphones Pianoteq6 flavor.

There are 17 add-on Instrument Packs selling for $59 each. (SteelPans has to be the most odd one) There are also 14 Free instruments you can add.

Have you tried the demo version?

Hi @C0d3man & @mheidt !

First of all … congratulations for your excelent work with the new Pianoteq engine! It’s a great step forward for putting Zynthian on the stages. As you know, i’m a great lover of Free Software, but the quality of Pianoteq emulation is so good, that i must recognize that there is nothing comparable in the Free Software world. That’s the true. Zynthian is and will be a completely Open Platform forever, but i think is good to have open doors for software like this. As a musician, i’m completely in love with it :heart_eyes:

As you know, i’ve bought a personal Pianoteq license with “Electric Pianos” & “Hohner Collection” pack and an extra “Steinway D”. As i told above, the quality of that software justify the money for those people that really want to have a proffessional “Zynthian Piano Station” :wink:

I’ve a technical question. You explain that:

But i see that the webconf tool have the possibility of adding a license key. Is it this option working OK or must i start Pianoteq GUI login with “ssh -Y” as you set in your post?


1 Like

The webonf displays the key only.
We need a new api call to get rid of the X11 forwarding step.

The current problem is, that you have to generate a license-request with Pianoteq and your license-key. Therefore you need the GUI. You can create a license online or offline with copying the generated request t oa stick and activating the license via browser. But theres no other way to generate the license-request without starting the Pianoteq-GUI (via ssh -X).

The current license-key entry in webconf is a kind of placeholder for later extending a in-system-license (if Modarrtt will support this feature).

Regards, Holger

Modartt released Pianoteq-6.1.1. Hope the new binary will also work with the engine.

Regards, Holger

[EDIT] :sob: Oh nooo… Modartt has improved their spatialisation technique which takes much more CPU. For now the new version 6.1 has drop-outs on the Raspi3. I have to try which parameters will work. Also there is currently a problem with reading the configuration file… fixes for Zynthian will come asap.

Ok - new features making it possible again to run Pianoteq-6.1.1 on the Raspi with not much problems. The feature is called “Multicore MAX”. I will fix this in the scripts after some testing.

Here are some examples (recorded by myself - so please excuse my not perfect playing :wink: )

Steinway D - Jazz:

Rhodes MKI - Flanger:

Rhodes MKII - Jazzy:

CP80 - Recording:

Regards, Holger


I have a license for PianoTeq 6 Standard. The web configuration tool seems to work only for PianoTeq Stage. Would it be possible to add support PianoTeq Standard (I may even do it, provided some guidance)?


P.S: this PianoTeq support brings Zynthian to another level yet, trying it for the first time practically brought me to tears.


Of course! Let’s do it, please :wink: I will be really happy of doing it or helping you. I would need the standard binary and the license key. Of course, after the task is done, i will delete the key and you can remove my device from the list. I’ve my “stage” license that is pretty enough for me :wink:

Ohhh! I’m in love with Pianoteq from the very first time i play a note. Having it on my zynthian is a f*** dream!! :heart_eyes:



Hi, after upgrading Pianoteq stage to version 6.3 (which btw. includes excellent czech made piano Antonín Petrof), the Pianoteq menu item disappeared from available layers list. I tried to update Zynthian and reboot, but it did not solve the problem.


When I tried to downgrade pianoteq to v 6.2, it got even worse: webconf on Software->Pianoteq gives me error 500 - where can i find webconf logs? And when selecting UI->NEW Synth Layer->Pianoteq 6.2 STAGE, it gives me “ERROR:root:Can’t add layer Pianoteq 6.2 STAGE => no element found: line 1, column 0” on console, when run with /zynthian/zynthian-sys/sbin/ Can i force-update pianoteq stuff and clean configuration from command line?

Are you upgrading demo versión? No license?


No, I have a license and used the upload form on webconf.

can I find webserver logs anywhere?

I did not have the energy to diagnose it more. What I did I reflashed the SD card, updated to the latest version of zynthian and installed pianoteq version 6.3 and activated the license again. Now it works ok.


There is no log. You need to start the webconf in a SSH session to see the error message.
Or zynthian itself, when you want to hunt a red error boot screen.

As i have explained several times, file journal is disabled in zynthian for reducing the risk of SD card corruption, but you can enable it by creating the “journal” directory in /var/log.